summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2018-07-11 11:42:12 +0300
committerIvan Maidanski <ivmai@mail.ru>2018-07-11 11:42:12 +0300
commit6a7af12cbd3d2c27a208cff577662fca7e729a93 (patch)
tree3d2cac38004564c98e913dd5b92415f742dde1b2 /configure.ac
parent0188393ec068ee5bb3117b78477cd19e0ddee452 (diff)
downloadbdwgc-6a7af12cbd3d2c27a208cff577662fca7e729a93.tar.gz
Fix build for Android after enabling handle-fork by default
(fix of commit 686a667) Issue #174 (bdwgc). * CMakeLists.txt [CMAKE_USE_PTHREADS_INIT]: Do not define HANDLE_FORK macro for android host. * configure.ac [$enable_handle_fork!=yes/no/manual && THREADS=xposix]: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3170309d..9c28962a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -864,6 +864,9 @@ elif test "${enable_handle_fork}" != manual -a x$THREADS = xposix; then
# If the option is omitted, pthread_atfork handlers are installed
# by default for the targets where pthread_atfork is known to work.
case "$host" in
+ *-*-android*)
+ # Android NDK does not provide pthread_atfork.
+ ;;
*-*-darwin*)
# The incremental mode (which is off if parallel marking) conflicts
# with fork handling on Darwin.