summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2017-05-05 21:04:25 +0300
committerIvan Maidanski <ivmai@mail.ru>2017-05-05 21:26:09 +0300
commit6d475d9bbb3155fd9d167816390e057262e5c81d (patch)
tree4c4ad2757b4b0ef220041f4cc71c5fd6d34e0397 /configure.ac
parent36d5f68f35711765dbe60521b842ddf8e584f868 (diff)
downloadbdwgc-6d475d9bbb3155fd9d167816390e057262e5c81d.tar.gz
Update documentation as parallel mark is now on by default in configure
(fix commit c7f2147) * configure.ac (parallel-mark): Provide information about --disable-parallel-mark option instead of --enable-parallel-mark. * doc/README.autoconf (Important options): Likewise. * doc/README.solaris2: Likewise. * doc/simple_example.html: Likewise. * doc/README.DGUX386: Remove configure --enable-parallel-mark option (as it is on by default now). * doc/README.autoconf (Important options): Do not provide information about --enable-full-debug which is no longer supported (since v7.0). * doc/gcinterface.html: update information about parallel marker mode in configure. * doc/README.solaris2: Provide information about --disable-threads option instead of --enable-threads=posix. * doc/simple_example.html: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f35591d8..7ea157d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,8 +112,8 @@ AC_ARG_ENABLE(threads,
AC_MSG_RESULT([$THREADS]) ])
AC_ARG_ENABLE(parallel-mark,
- [AC_HELP_STRING([--enable-parallel-mark],
- [parallelize marking and free list construction])],
+ [AC_HELP_STRING([--disable-parallel-mark],
+ [do not parallelize marking and free list construction])],
[case "$THREADS" in
no | none | single)
if test "${enable_parallel_mark}" != no; then