summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2016-08-18 01:15:20 +0300
committerIvan Maidanski <ivmai@mail.ru>2016-08-18 01:23:57 +0300
commit6eb61a6787ba5718679ee159d6f0a4f08416a092 (patch)
tree57b97d7457d051685d4f79268c46789d8a1f3777 /configure.ac
parent6af3f60ef669eb70f5b7d0529a6eeb0ec6ffac66 (diff)
downloadbdwgc-6eb61a6787ba5718679ee159d6f0a4f08416a092.tar.gz
Fix compilation if configured with --enable-werror on OS X
GC_init_dyld uses _dyld_bind_fully_image_containing_address() which is deprecated starting from OS X 10.5. * configure.ac (werror): Add -Wno-deprecated-declarations to WERROR_CFLAGS if host is darwin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b0701a48..bf03f454 100644
--- a/configure.ac
+++ b/configure.ac
@@ -904,6 +904,12 @@ AC_ARG_ENABLE(werror, [--enable-werror Pass -Werror to the C compiler],
werror_flag=$enableval, werror_flag=no)
if test x$werror_flag = xyes; then
WERROR_CFLAGS="-Werror"
+ case "$host" in
+ # _dyld_bind_fully_image_containing_address is deprecated in OS X 10.5+
+ *-*-darwin*)
+ WERROR_CFLAGS="$WERROR_CFLAGS -Wno-deprecated-declarations"
+ ;;
+ esac
fi
AC_SUBST([WERROR_CFLAGS])