summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2014-08-10 11:47:09 +0400
committerIvan Maidanski <ivmai@mail.ru>2014-08-10 13:06:36 +0400
commitb41c6771a3405eb9074651a7638639edbf662245 (patch)
tree8fb755ab721914d34b4da663408a431e60a6073b /configure.ac
parent8d74a8bea74bcc0e41ec104ca7a17a6f8d6e566d (diff)
downloadbdwgc-b41c6771a3405eb9074651a7638639edbf662245.tar.gz
Fix pthreads-win32 name in comments and documentation
* configure.ac (GC_WIN32_PTHREADS): Fix pthreads-win32 name. * doc/README.macros (GC_WIN32_PTHREADS): Likewise. * doc/README.win32: Likewise. * include/gc.h (GC_WIN32_THREADS): Likewise. * include/gc_config_macros.h (GC_WIN32_PTHREADS): Likewise. * include/private/gc_locks.h (NUMERIC_THREAD_ID): Likewise. * win32_threads.c (GC_pthread_join): Likewise. * doc/README.win32: Add information how to build for Win32 with pthreads-win32 using configure. * include/private/gc_locks.h (NUMERIC_THREAD_ID): Adjust comment (capitalize 1st word of a sentence, add dot at sentence end). * win32_threads.c (GC_pthread_join): Join adjacent GC_WIN32_PTHREADS checks; refine comment about pthreads-win32 id.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 32982b0f..fac8edd3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,7 +145,7 @@ AH_TEMPLATE([GC_OPENBSD_THREADS], [Define to support OpenBSD pthreads.])
AH_TEMPLATE([GC_OSF1_THREADS], [Define to support Tru64 pthreads.])
AH_TEMPLATE([GC_SOLARIS_THREADS], [Define to support Solaris pthreads.])
AH_TEMPLATE([GC_WIN32_THREADS], [Define to support Win32 threads.])
-AH_TEMPLATE([GC_WIN32_PTHREADS], [Define to support win32-pthreads.])
+AH_TEMPLATE([GC_WIN32_PTHREADS], [Define to support pthreads-win32.])
AH_TEMPLATE([GC_RTEMS_PTHREADS], [Define to support rtems-pthreads.])
dnl System header feature requests.
@@ -275,7 +275,7 @@ case "$THREADS" in
;;
*-*-mingw*)
AC_DEFINE(GC_WIN32_PTHREADS)
- # Using win32-pthreads
+ # Using pthreads-win32 library.
if test "${enable_parallel_mark}" != no; then
AC_DEFINE(PARALLEL_MARK)
fi