summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Budai <peterbudai@hotmail.com>2018-09-15 11:35:20 +0200
committerIvan Maidanski <ivmai@mail.ru>2019-03-20 09:12:33 +0300
commitda7c974c473c0cc5e15c18f25cd246ac02bd5c23 (patch)
treecef97fb6b40c7e9917ac5dbaebc066f038066a31 /configure.ac
parent514b35d452070315f3a90766ba6cba5f8755eb7c (diff)
downloadbdwgc-da7c974c473c0cc5e15c18f25cd246ac02bd5c23.tar.gz
Support MSYS builds in configure
* configure.ac [$THREADS=pthreads && $host=*-*-msys*] (GC_THREADS, _REENTRANT): Define AC macro. * configure.ac [$THREADS=pthreads && $host=*-*-msys*] (use_parallel_mark, use_thread_local_alloc, THREADDLLIBS, win32_threads): Set variable. * configure.ac [$host=*-*-msys*]: Do not AC_CHECK_LIB(dl). * configure.ac [$GCC=yes && $enable_cplusplus=yes && $host=*-*-msys* && $SUPC!="libsupc++.a"] (CXXLIBS): Set variable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 49af3626..1b282e50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,7 +200,7 @@ case "$THREADS" in
case "$host" in
*-*-aix* | *-*-android* | *-*-cygwin* | *-*-darwin* | *-*-dragonfly* | \
*-*-freebsd* | *-*-haiku* | *-*-hpux11* | *-*-irix* | \
- *-*-kfreebsd*-gnu | *-*-gnu* | *-*-*linux* | *-*-nacl* | \
+ *-*-kfreebsd*-gnu | *-*-gnu* | *-*-*linux* | *-*-msys* | *-*-nacl* | \
*-*-netbsd* | *-*-openbsd* | *-*-osf* | *-*-solaris*)
AC_DEFINE(GC_THREADS)
AC_DEFINE([_REENTRANT], [1],
@@ -241,7 +241,7 @@ case "$THREADS" in
*-*-solaris*)
THREADDLLIBS="-lpthread -lrt"
;;
- *-*-cygwin*)
+ *-*-cygwin* | *-*-msys*)
# Cygwin doesn't have a real libpthread, so Libtool can't link
# against it.
THREADDLLIBS=""
@@ -435,8 +435,8 @@ case "$host" in
mips-sgi-irix6*) ;;
# We never want libdl on darwin. It is a fake libdl that just ends up making
# dyld calls anyway. The same applies to Cygwin.
- *-*-darwin*) ;;
- *-*-cygwin*) ;;
+ *-*-cygwin* | *-*-darwin* | *-*-msys*)
+ ;;
*)
AC_CHECK_LIB(dl, dlopen, THREADDLLIBS="$THREADDLLIBS -ldl")
;;
@@ -497,7 +497,7 @@ AM_CONDITIONAL(CPLUSPLUS, test "${enable_cplusplus}" = yes)
if test "$GCC" = yes; then
if test "${enable_cplusplus}" = yes; then
case "$host" in
- *-*-cygwin* | *-*-mingw*)
+ *-*-cygwin* | *-*-mingw* | *-*-msys*)
AC_MSG_CHECKING([whether libsupc++ required])
SUPC="`$CXX -print-file-name=libsupc++.a 2>/dev/null`"
if test -n "$SUPC" -a "$SUPC" != "libsupc++.a"; then