summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1aa0c4b6..282c8b1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -551,10 +551,8 @@ if (install_headers)
install(FILES include/gc.h
include/gc_backptr.h
include/gc_config_macros.h
- include/gc_gcj.h
include/gc_inline.h
include/gc_mark.h
- include/gc_pthread_redirects.h
include/gc_tiny_fl.h
include/gc_typed.h
include/gc_version.h
@@ -573,6 +571,14 @@ if (install_headers)
install(FILES include/gc_disclaim.h
DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/gc")
endif()
+ if (enable_gcj_support)
+ install(FILES include/gc_gcj.h
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/gc")
+ endif()
+ if (enable_threads AND CMAKE_USE_PTHREADS_INIT)
+ install(FILES include/gc_pthread_redirects.h
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/gc")
+ endif()
if (build_cord)
install(FILES include/cord.h
include/cord_pos.h