summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9e11847..7bf50784 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -394,6 +394,11 @@ endif(enable_checksums)
if (enable_werror)
if (BORLAND)
add_compile_options(/w!)
+ if (enable_threads)
+ # Workaround "function should return a value" warning for several
+ # asm functions in atomic_ops/sysdeps/msftc/x86.h.
+ add_compile_options(/w-rvl)
+ endif(enable_threads)
elseif (MSVC)
add_compile_options(/WX)
# Workaround "typedef ignored on left of ..." warning reported in