summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGuo Yejun <yejun.guo@intel.com>2014-05-30 06:29:09 +0800
committerZhigang Gong <zhigang.gong@intel.com>2014-05-30 14:23:04 +0800
commitf9074f9ff4e24da2ee92fc84a8dcff0604346d28 (patch)
tree575092aec22f32f1de447c499fe3bf6d0eaa7fc9 /src/CMakeLists.txt
parentc34eba71bd5a518906d6d5d3ba26e44327cab251 (diff)
downloadbeignet-f9074f9ff4e24da2ee92fc84a8dcff0604346d28.tar.gz
extract libgbeinterp.so from runtime (libcl.so)
currently, there are same symbol names in libinterp.a (inside libcl.so) and libgbe.so (compiler), and so have to dlopen libgbe.so with RTLD_DEEPBIND, this flag makes std::cerr inside libgbe crash. extract the interp part from libcl.so as libgbeinterp.so, therefore, first dlopen libgbe.so without RTLD_DEEPBIND, then dlopen libgbeinterp.so with RTLD_DEEPBIND, to fix the std:cerr crash issue. Signed-off-by: Guo Yejun <yejun.guo@intel.com> Reviewed-by: Zhigang Gong <zhigang.gong@linux.intel.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4c2b0277..a8d35d65 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -99,7 +99,6 @@ link_directories (${LLVM_LIBRARY_DIR})
add_library(cl SHARED ${OPENCL_SRC})
target_link_libraries(
cl
- interp
${XLIB_LIBRARY}
${XEXT_LIBRARIES}
${XFIXES_LIBRARIES}