summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2021-11-25 14:26:51 +1030
committerAlan Modra <amodra@gmail.com>2021-11-25 22:44:56 +1030
commit32384aa396e7e87fe02cc838722b8e80ec88ec10 (patch)
tree98fd4ab9d73b5e686afeef38fc32c545ef7f58c9 /bfd/Makefile.am
parent79abb939304111e0d303b331b7b7ea005cf116f5 (diff)
downloadbinutils-gdb-32384aa396e7e87fe02cc838722b8e80ec88ec10.tar.gz
Re: AArch64: Add support for AArch64 EFI (efi-*-aarch64)
Commit b69c9d41e8 edited bfd/Makefile.in rather than using automake, which meant a typo in Makefile.am was not discovered and other differences in Makefile.in are seen with a proper regeneration. One difference was lack of an empty line between the pe-aarch64igen.c rule and the following $(BFD32_LIBS) etc. dependency rule, in the regenerated file. Not that it matters for proper "make" behaviour, but it's nicer with a line between those rules. Moving the rule earlier seems to cure the missing empty line. * Makefile.am (BFD64_BACKENDS): Correct typo. (BFD_H_DEPS, LOCAL_H_DEPS): Move earlier. Move rule using these deps earlier too. * Makefile.in: Regenerate. * po/BLD-POTFILES.in: Regenerate. * po/SRC-POTFILES.in: Regenerate.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index d0798c340ab..86ed7675052 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -574,7 +574,7 @@ BFD64_BACKENDS = \
mmo.lo \
pe-aarch64igen.lo \
pe-x86_64.lo \
- pei-aarch64lo \
+ pei-aarch64.lo \
pei-ia64.lo \
pei-x86_64.lo \
pepigen.lo \
@@ -717,6 +717,15 @@ BUILT_SOURCES = $(BUILD_HFILES)
HFILES = $(SOURCE_HFILES) $(BUILD_HFILES)
+BFD_H_DEPS = $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h $(INCDIR)/diagnostics.h
+LOCAL_H_DEPS = libbfd.h sysdep.h config.h
+$(BFD32_LIBS) \
+ $(BFD64_LIBS) \
+ $(ALL_MACHINES) \
+ $(BFD32_BACKENDS) \
+ $(BFD64_BACKENDS) \
+ $(OPTIONAL_BACKENDS): $(BFD_H) $(BFD_H_DEPS) $(LOCAL_H_DEPS)
+
SRC_POTFILES = $(SOURCE_CFILES) $(SOURCE_HFILES)
BLD_POTFILES = $(BUILD_CFILES) $(BUILD_HFILES)
@@ -884,15 +893,6 @@ pe-aarch64igen.c: peXXigen.c
echo "#line 1 \"peXXigen.c\"" > $@
$(SED) -e s/XX/peAArch64/g < $< >> $@
-BFD_H_DEPS= $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h $(INCDIR)/diagnostics.h
-LOCAL_H_DEPS= libbfd.h sysdep.h config.h
-$(BFD32_LIBS) \
- $(BFD64_LIBS) \
- $(ALL_MACHINES) \
- $(BFD32_BACKENDS) \
- $(BFD64_BACKENDS) \
- $(OPTIONAL_BACKENDS): $(BFD_H) $(BFD_H_DEPS) $(LOCAL_H_DEPS)
-
host-aout.lo: Makefile
# The following program can be used to generate a simple config file