summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2022-10-06 09:45:56 +1030
committerAlan Modra <amodra@gmail.com>2022-10-06 09:45:56 +1030
commit769a27ade5880ae760b061863f0e9d33e7633d84 (patch)
treee9998a1abda8ec50ee3d1dc475f70ffd47e3d8bf /bfd/Makefile.am
parente87fb6a6d0cdfc0e9c471b7825c20c238c2cf506 (diff)
downloadbinutils-gdb-769a27ade5880ae760b061863f0e9d33e7633d84.tar.gz
Re: bfd BLD-POTFILES.in dependencies
Removing $BLD_POTFILES from BFD-POTFILES.in was correct, but left a hole in dependencies. make[4]: Entering directory '/home/alan/build/gas/all/bfd/po' make[4]: *** No rule to make target '../elf32-aarch64.c', needed by '/home/alan/src/binutils-gdb/bfd/po/bfd.pot'. Stop. * Makefile.am (BUILT_SOURCES): Add BUILD_CFILES. * Makefile.in: Regenerate.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 98a487b7fcd..794d992310d 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -719,7 +719,7 @@ BUILD_HFILES = \
bfdver.h elf32-target.h elf64-target.h targmatch.h
# Ensure they are built early:
-BUILT_SOURCES = $(BUILD_HFILES)
+BUILT_SOURCES = $(BUILD_HFILES) $(BUILD_CFILES)
HFILES = $(SOURCE_HFILES) $(BUILD_HFILES)