summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2019-09-23 10:15:02 +0930
committerAlan Modra <amodra@gmail.com>2019-09-23 10:27:22 +0930
commitb06252c2b1972d31d3e263ba4a7e79aecec73255 (patch)
treecc2f0528e8da26bc8f4b3bb62fde7744731f4c59 /bfd/Makefile.am
parent640197ac27920a9f0a23283a575dc71f74e8b8ab (diff)
downloadbinutils-gdb-b06252c2b1972d31d3e263ba4a7e79aecec73255.tar.gz
bfd Makefile update
* Makefile.am (SOURCE_HFILES): Add many missing .h files. * Makefile.in: Regenerate. * po/SRC-POTFILES.in: Regenerate.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am32
1 files changed, 24 insertions, 8 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 4703955ee4e..f31a7345994 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -684,19 +684,35 @@ BUILD_CFILES = \
CFILES = $(SOURCE_CFILES) $(BUILD_CFILES)
-## This is a list of all .h files which are in the source tree.
+## This is a list of all .h files in the source tree minus those that
+## are processed to produce other .h files
SOURCE_HFILES = \
- aout-target.h aoutx.h coffcode.h coffswap.h ecoffswap.h \
- elf-bfd.h elf-hppa.h elf-linux-core.h elf32-hppa.h \
- elf64-hppa.h elfcode.h elfcore.h \
+ aout-target.h aoutx.h arc-got.h arc-plt.h \
+ coff-arm.h coff-bfd.h coffcode.h coffswap.h \
+ cpu-aarch64.h cpu-arm.h cpu-h8300.h cpu-m68k.h \
+ ecoff-bfd.h ecoffswap.h \
+ elf32-arm.h elf32-avr.h elf32-bfin.h elf32-cr16.h elf32-csky.h \
+ elf32-dlx.h elf32-hppa.h elf32-m68hc1x.h elf32-m68k.h \
+ elf32-metag.h elf32-nds32.h elf32-nios2.h elf32-ppc.h \
+ elf32-rx.h elf32-score.h elf32-sh-relocs.h elf32-spu.h \
+ elf32-tic6x.h elf32-tilegx.h elf32-tilepro.h elf32-v850.h \
+ elf64-hppa.h elf64-ppc.h elf64-tilegx.h \
+ elf-bfd.h elfcode.h elfcore.h elf-hppa.h elf-linker-x86.h \
+ elf-linux-core.h elf-nacl.h elf-s390.h elf-vxworks.h \
+ elfxx-aarch64.h elfxx-ia64.h elfxx-mips.h elfxx-riscv.h \
+ elfxx-sparc.h elfxx-tilegx.h elfxx-x86.h \
genlink.h go32stub.h \
libaout.h libbfd.h libcoff.h libecoff.h libhppa.h \
- libpei.h libxcoff.h mach-o.h \
+ libpei.h libxcoff.h \
+ mach-o.h \
netbsd.h ns32k.h \
- pef.h pef-traceback.h peicode.h som.h version.h \
- vms.h xsym.h
+ pef.h pef-traceback.h peicode.h plugin.h \
+ som.h sysdep.h \
+ version.h vms.h \
+ wasm-module.h \
+ xcofflink.h xsym.h
-## ... and all .h files which are in the build tree.
+## ... and .h files which are in the build tree, minus config.h and bfd.h
BUILD_HFILES = \
bfdver.h elf32-target.h elf64-target.h targmatch.h bfd_stdint.h