summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2018-04-16 15:33:26 +0930
committerAlan Modra <amodra@gmail.com>2018-04-16 15:33:26 +0930
commitc9098af41e3246586a30f4f0bdb0ee4367e9a5e7 (patch)
tree8e9536dd5e0e1227e0e311b811d029dba4e14b3f /bfd/Makefile.am
parentdc12032bca08554cf0a72d224e44f755f7789ff3 (diff)
downloadbinutils-gdb-c9098af41e3246586a30f4f0bdb0ee4367e9a5e7.tar.gz
Remove sparc-aout and sparc-coff support
bfd/ * Makefile.am: Remove sparc-aout and sparc-coff support. * config.bfd: Likewise. * configure.ac: Likewise. * targets.c: Likewise. * aout-sparcle.c: Delete. * aoutf1.h: Delete. * cf-sparclynx.c: Delete. * coff-sparc.c: Delete. * demo64.c: Delete. * sparclinux.c: Delete. * sparclynx.c: Delete. * sparcnetbsd.c: Delete. * sunos.c: Delete. * Makefile.in: Regenerate. * configure: Regenerate. * po/SRC-POTFILES.in: Regenerate. binutils/ * testsuite/lib/binutils-common.exp: Remove sparc-aout and sparc-coff support. gas/ * Makefile.am: Remove sparc-aout and sparc-coff support. * config/obj-coff.h: Likewise. * config/tc-sparc.c: Likewise. * config/tc-sparc.h: Likewise. * configure.tgt: Likewise. * config/te-sparcaout.h: Delete. * testsuite/gas/sun4/addend.d: Delete. * testsuite/gas/sun4/addend.exp: Delete. * testsuite/gas/sun4/addend.s: Delete. * Makefile.in: Regenerate. * po/POTFILES.in: Regenerate. ld/ * Makefile.am: Remove sparc-aout and sparc-coff support. * configure.tgt: Likewise. * testsuite/ld-elfvers/vers.exp: Likewise. * testsuite/ld-elfvsb/elfvsb.exp: Likewise. * testsuite/ld-elfweak/elfweak.exp: Likewise. * testsuite/ld-shared/shared.exp: Likewise. * emulparams/coff_sparc.sh: Delete. * emulparams/sparcaout.sh: Delete. * emulparams/sparclinux.sh: Delete. * emulparams/sparcnbsd.sh: Delete. * emulparams/sun4.sh: Delete. * scripttempl/sparccoff.sc: Delete. * Makefile.in: Regenerate. * po/BLD-POTFILES.in: Regenerate.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am18
1 files changed, 1 insertions, 17 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 1e92647e7f0..9ba5db02c82 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -260,19 +260,16 @@ BFD32_BACKENDS = \
aout-arm.lo \
aout-cris.lo \
aout-ns32k.lo \
- aout-sparcle.lo \
aout-tic30.lo \
aout32.lo \
armnetbsd.lo \
cf-i386lynx.lo \
- cf-sparclynx.lo \
coff-arm.lo \
coff-go32.lo \
coff-i386.lo \
coff-mips.lo \
coff-rs6000.lo \
coff-sh.lo \
- coff-sparc.lo \
coff-stgo32.lo \
coff-tic30.lo \
coff-tic4x.lo \
@@ -400,10 +397,6 @@ BFD32_BACKENDS = \
reloc16.lo \
riscix.lo \
som.lo \
- sparclinux.lo \
- sparclynx.lo \
- sparcnetbsd.lo \
- sunos.lo \
vax1knetbsd.lo \
vaxnetbsd.lo \
vms-lib.lo \
@@ -418,19 +411,16 @@ BFD32_BACKENDS_CFILES = \
aout-arm.c \
aout-cris.c \
aout-ns32k.c \
- aout-sparcle.c \
aout-tic30.c \
aout32.c \
armnetbsd.c \
cf-i386lynx.c \
- cf-sparclynx.c \
coff-arm.c \
coff-go32.c \
coff-i386.c \
coff-mips.c \
coff-rs6000.c \
coff-sh.c \
- coff-sparc.c \
coff-stgo32.c \
coff-tic30.c \
coff-tic4x.c \
@@ -557,10 +547,6 @@ BFD32_BACKENDS_CFILES = \
reloc16.c \
riscix.c \
som.c \
- sparclinux.c \
- sparclynx.c \
- sparcnetbsd.c \
- sunos.c \
vax1knetbsd.c \
vaxnetbsd.c \
vms-lib.c \
@@ -585,7 +571,6 @@ BFD64_BACKENDS = \
coff-alpha.lo \
coff-x86_64.lo \
coff64-rs6000.lo \
- demo64.lo \
elf32-ia64.lo \
elf32-mips.lo \
elf32-score.lo \
@@ -626,7 +611,6 @@ BFD64_BACKENDS_CFILES = \
coff-alpha.c \
coff-x86_64.c \
coff64-rs6000.c \
- demo64.c \
elf32-mips.c \
elf32-score.c \
elf32-score7.c \
@@ -717,7 +701,7 @@ CFILES = $(SOURCE_CFILES) $(BUILD_CFILES)
## This is a list of all .h files which are in the source tree.
SOURCE_HFILES = \
- aout-target.h aoutf1.h aoutx.h coffcode.h coffswap.h ecoffswap.h \
+ aout-target.h aoutx.h coffcode.h coffswap.h ecoffswap.h \
elf-bfd.h elf-hppa.h elf-linux-core.h elf32-hppa.h \
elf64-hppa.h elfcode.h elfcore.h \
freebsd.h genlink.h go32stub.h \