summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2022-09-22 07:48:00 +0930
committerAlan Modra <amodra@gmail.com>2022-09-22 08:14:55 +0930
commitd13102c03e56218efe1567122305f3bff89c0672 (patch)
treef07e29f04e97adcdb7cb72e9f38c58b84fa6ada9 /bfd/Makefile.am
parent517a63c2c48e5aaabe57de079e2d7f0bea09429b (diff)
downloadbinutils-gdb-d13102c03e56218efe1567122305f3bff89c0672.tar.gz
bfd BLD-POTFILES.in dependencies
A file that consists of a list of files doesn't depend on those files being built. This patch came from trying to avoid a maintainer-mode make -j bug, where the recipe for targmatch.h was being run twice in parallel. Typical output shown below. make[2]: Entering directory '/build/gas/all/bfd' GEN bfdver.h GEN elf32-target.h GEN elf64-target.h GEN targmatch.h Making info in po make[3]: Entering directory '/build/gas/all/bfd/po' cd .. && make po/SRC-POTFILES.in cd .. && make po/BLD-POTFILES.in make[4]: Entering directory '/build/gas/all/bfd' GEN elf32-aarch64.c GEN elf64-aarch64.c GEN elf32-ia64.c GEN elf64-ia64.c GEN elf32-loongarch.c GEN elf64-loongarch.c GEN elf32-riscv.c GEN elf64-riscv.c GEN peigen.c GEN pepigen.c GEN pex64igen.c GEN pe-aarch64igen.c GEN targmatch.h make[4]: Entering directory '/build/gas/all/bfd' CCLD doc/chew.stamp mv: cannot stat 'targmatch.new': No such file or directory make[4]: *** [Makefile:2325: targmatch.h] Error 1 * Makefile.am (po/BLD-POTFILES.in): Don't depend on $(BLD_POTFILES). (po/SRC-POTFILES.in): Don't depend on $(SRC_POTFILES).
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 04fb335d47d..c23dff6cac3 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -735,12 +735,12 @@ $(BFD32_LIBS) \
SRC_POTFILES = $(SOURCE_CFILES) $(SOURCE_HFILES)
BLD_POTFILES = $(BUILD_CFILES) $(BUILD_HFILES)
-po/SRC-POTFILES.in: @MAINT@ Makefile $(SRC_POTFILES)
+po/SRC-POTFILES.in: @MAINT@ Makefile
for file in $(SRC_POTFILES); do echo $$file; done \
| LC_ALL=C sort > tmp.src \
&& mv tmp.src $(srcdir)/po/SRC-POTFILES.in
-po/BLD-POTFILES.in: @MAINT@ Makefile $(BLD_POTFILES)
+po/BLD-POTFILES.in: @MAINT@ Makefile
for file in $(BLD_POTFILES); do echo $$file; done \
| LC_ALL=C sort > tmp.bld \
&& mv tmp.bld $(srcdir)/po/BLD-POTFILES.in