summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorliuzhensong <liuzhensong@loongson.cn>2021-10-22 16:42:03 +0800
committerAlan Modra <amodra@gmail.com>2021-10-24 21:36:31 +1030
commite214f8db56f65531b0a5ec296c42339dcaa5af31 (patch)
tree98bd755197a63aaf79bda89bb3ea792e5a49aaab /bfd/Makefile.am
parente515d93264b8c74993d8c9f3ac76bd6deaa666f8 (diff)
downloadbinutils-gdb-e214f8db56f65531b0a5ec296c42339dcaa5af31.tar.gz
LoongArch bfd support
2021-10-22 Chenghua Xu <xuchenghua@loongson.cn> Zhensong Liu <liuzhensong@loongson.cn> Weinan Liu <liuweinan@loongson.cn> bfd/ * Makefile.am: Add LoongArch. * archures.c: Likewise. * config.bfd: Likewise. * configure.ac: Likewise. * cpu-loongarch.c: New. * elf-bfd.h: Add LoongArch. * elf.c: Add LoongArch elfcore_grok_xxx. * elfnn-loongarch.c: New. * elfxx-loongarch.c: New. * elfxx-loongarch.h: New. * reloc.c: Add LoongArch BFD RELOC ENUM. * targets.c: Add LoongArch target. * Makefile.in: Regenerate. * bfd-in2.h: Regenerate. * configure: Regenerate. * libbfd.h: Regenerate. * po/BLD-POTFILES.in: Regenerate. * po/SRC-POTFILES.in: Regenerate. include/ * elf/common.h: Add NT_LARCH_{CPUCFG,CSR,LSX,LASX}. * elf/loongarch.h: New.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index ed2f701805d..097177bae5c 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -118,6 +118,7 @@ ALL_MACHINES = \
cpu-ip2k.lo \
cpu-iq2000.lo \
cpu-lm32.lo \
+ cpu-loongarch.lo \
cpu-m10200.lo \
cpu-m10300.lo \
cpu-m32c.lo \
@@ -202,6 +203,7 @@ ALL_MACHINES_CFILES = \
cpu-ip2k.c \
cpu-iq2000.c \
cpu-lm32.c \
+ cpu-loongarch.c \
cpu-m10200.c \
cpu-m10300.c \
cpu-m32c.c \
@@ -548,6 +550,9 @@ BFD64_BACKENDS = \
elf64-ia64.lo \
elf64-ia64-vms.lo \
elfxx-ia64.lo \
+ elf32-loongarch.lo \
+ elf64-loongarch.lo \
+ elfxx-loongarch.lo \
elfn32-mips.lo \
elf64-mips.lo \
elfxx-mips.lo \
@@ -601,6 +606,7 @@ BFD64_BACKENDS_CFILES = \
elfn32-mips.c \
elfxx-aarch64.c \
elfxx-ia64.c \
+ elfxx-loongarch.c \
elfxx-mips.c \
elfxx-riscv.c \
mach-o-aarch64.c \
@@ -665,6 +671,7 @@ SOURCE_CFILES = \
BUILD_CFILES = \
elf32-aarch64.c elf64-aarch64.c \
elf32-ia64.c elf64-ia64.c \
+ elf32-loongarch.c elf64-loongarch.c \
elf32-riscv.c elf64-riscv.c \
peigen.c pepigen.c pex64igen.c
@@ -686,7 +693,7 @@ SOURCE_HFILES = \
elf-bfd.h elfcode.h elfcore.h elf-hppa.h elf-linker-x86.h \
elf-linux-core.h elf-nacl.h elf-s390.h elf-vxworks.h \
elfxx-aarch64.h elfxx-ia64.h elfxx-mips.h elfxx-riscv.h \
- elfxx-sparc.h elfxx-tilegx.h elfxx-x86.h \
+ elfxx-sparc.h elfxx-tilegx.h elfxx-x86.h elfxx-loongarch.h \
genlink.h go32stub.h \
libaout.h libbfd.h libcoff.h libecoff.h libhppa.h \
libpei.h libxcoff.h \
@@ -842,6 +849,14 @@ elf64-ia64.c : elfnn-ia64.c
echo "#line 1 \"elfnn-ia64.c\"" > $@
$(SED) -e s/NN/64/g < $< >> $@
+elf32-loongarch.c : elfnn-loongarch.c
+ echo "#line 1 \"elfnn-loongarch.c\"" > $@
+ $(SED) -e s/NN/32/g < $< >> $@
+
+elf64-loongarch.c : elfnn-loongarch.c
+ echo "#line 1 \"elfnn-loongarch.c\"" > $@
+ $(SED) -e s/NN/64/g < $< >> $@
+
elf32-riscv.c : elfnn-riscv.c
echo "#line 1 \"elfnn-riscv.c\"" > $@
$(SED) -e s/NN/32/g < $< >> $@