summaryrefslogtreecommitdiff
path: root/binutils/configure.ac
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2022-08-12 17:47:51 +0930
committerAlan Modra <amodra@gmail.com>2022-08-13 14:11:27 +0930
commit31e5a3a3807e7d5b43845d0d17ddfd1a8692752c (patch)
tree3fc68ca03ec7226ba6af6e92b60d79e0bb747d41 /binutils/configure.ac
parent625d49fce79d6154de07edc00b36335e7e7a0479 (diff)
downloadbinutils-gdb-31e5a3a3807e7d5b43845d0d17ddfd1a8692752c.tar.gz
Make dwarf_vma uint64_t
This replaces dwarf_vma, dwarf_size_type and dwarf_signed_vma with uint64_t and int64_t everywhere. The patch also gets rid of DWARF_VMA_FMT since we can't use that with uint64_t, and all of the configure support for deciding the flavour of HOST_WIDEST_INT. dwarf_vmatoa also disappears, replacing most uses with one of PRIx64, PRId64 or PRIu64. Printing of size_t and ptrdiff_t values now use %z and %t rather than by casting to unsigned long. Also, most warning messages that used 0x%lx or similar now use %#lx and a few that didn't print the 0x hex prefix now also use %#. The patch doesn't change normal readelf output, except in odd cases where values previously might have been truncated.
Diffstat (limited to 'binutils/configure.ac')
-rw-r--r--binutils/configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/binutils/configure.ac b/binutils/configure.ac
index 50dac4ee8f4..ec002d3f88f 100644
--- a/binutils/configure.ac
+++ b/binutils/configure.ac
@@ -174,9 +174,6 @@ case "${host}" in
esac
AC_SUBST(DEMANGLER_NAME)
-AC_CHECK_SIZEOF([long])
-AC_CHECK_SIZEOF([long long])
-
# We use headers from include/ that check various HAVE_*_H macros, thus
# should ensure they are set by configure. This is true even when C99
# guarantees they are available.