summaryrefslogtreecommitdiff
path: root/binutils/configure.ac
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2022-07-22 12:11:24 +0930
committerAlan Modra <amodra@gmail.com>2022-07-22 12:38:53 +0930
commit6577f365ebdee7dda71cb996efa29d3714cbccd0 (patch)
treec32ad75f7c51c1c9100a18ce3e7883c2dacd434a /binutils/configure.ac
parent4686f81068433540a8dcf1104548389922e2bfef (diff)
downloadbinutils-gdb-6577f365ebdee7dda71cb996efa29d3714cbccd0.tar.gz
PR17122, OSX 10.9 build failure
sbrk hasn't been used in binutils/ or ld/ for quite some time (so the PR was fixed a while ago). Tidy up configury. PR 17122 binutils/ * configure.ac: Don't check for sbrk. * sysdep.h (sbrk): Don't supply fallback declaration. * config.in: Regenerate. * configure: Regenerate. ld/ * configure.ac: Don't check for sbrk. * config.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'binutils/configure.ac')
-rw-r--r--binutils/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/binutils/configure.ac b/binutils/configure.ac
index e204a201a0a..50dac4ee8f4 100644
--- a/binutils/configure.ac
+++ b/binutils/configure.ac
@@ -186,7 +186,7 @@ AC_CHECK_HEADERS(fcntl.h inttypes.h stdint.h sys/file.h \
sys/stat.h sys/time.h sys/types.h unistd.h)
AC_HEADER_SYS_WAIT
AC_FUNC_MMAP
-AC_CHECK_FUNCS(getc_unlocked mkdtemp mkstemp sbrk utimensat utimes)
+AC_CHECK_FUNCS(getc_unlocked mkdtemp mkstemp utimensat utimes)
AC_MSG_CHECKING([for mbstate_t])
AC_TRY_COMPILE([#include <wchar.h>],
@@ -266,7 +266,7 @@ if test $bu_cv_header_utime_h = yes; then
AC_DEFINE(HAVE_GOOD_UTIME_H, 1, [Does <utime.h> define struct utimbuf?])
fi
-AC_CHECK_DECLS([asprintf, environ, getc_unlocked, sbrk, stpcpy, strnlen])
+AC_CHECK_DECLS([asprintf, environ, getc_unlocked, stpcpy, strnlen])
# Link in zlib if we can. This allows us to read compressed debug
# sections. This is used only by readelf.c (objdump uses bfd for