summaryrefslogtreecommitdiff
path: root/binutils/configure.ac
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2020-11-20 13:04:56 +0000
committerNick Clifton <nickc@redhat.com>2020-11-20 13:04:56 +0000
commite6f6aa8d184c38230d9acd91a49aa0cbe3f37e42 (patch)
treee79643c26315046beb132228fdbb4d26b025e4fa /binutils/configure.ac
parent8881640c8071b04fa2566f21eb2a47e691caf11c (diff)
downloadbinutils-gdb-e6f6aa8d184c38230d9acd91a49aa0cbe3f37e42.tar.gz
Add option to nm to change the characters displayed for ifunc symbols. Add a configure time option to change the default characters.
PR 22967 * nm.c (ifunc_type_chars): New variable. (long_options): Add --ifunc-chars. (print_symbol): Use ifunc_type_chars for ifunc symbols. (main): Handle the new option. * doc/binutils.texi: Document the new option. * configure.ac: Add --enable-f-for-ifunc-symbols option which changes the default symbol displayed by nm. * NEWS: Mention the new feature. * testsuite/binutils-all/nm.exp: Test the new feature. * config.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'binutils/configure.ac')
-rw-r--r--binutils/configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/binutils/configure.ac b/binutils/configure.ac
index 883f3187e72..24bf102019d 100644
--- a/binutils/configure.ac
+++ b/binutils/configure.ac
@@ -43,6 +43,7 @@ AC_ARG_ENABLE(targets,
*) enable_targets=$enableval ;;
esac])dnl
+
AC_ARG_ENABLE(deterministic-archives,
[AS_HELP_STRING([--enable-deterministic-archives],
[ar and ranlib default to -D behavior])], [
@@ -55,6 +56,7 @@ fi], [default_ar_deterministic=0])
AC_DEFINE_UNQUOTED(DEFAULT_AR_DETERMINISTIC, $default_ar_deterministic,
[Should ar and ranlib use -D behavior by default?])
+
AC_ARG_ENABLE(default-strings-all,
[AS_HELP_STRING([--disable-default-strings-all],
[strings defaults to --data behavior])], [
@@ -64,11 +66,24 @@ else
default_strings_all=1
fi], [default_strings_all=1])
-AC_DEBUGINFOD
-
AC_DEFINE_UNQUOTED(DEFAULT_STRINGS_ALL, $default_strings_all,
[Should strings use -a behavior by default?])
+
+AC_ARG_ENABLE(f-for-ifunc-symbols,
+[AS_HELP_STRING([--enable-f-for-ifunc-symbols],
+ [Have nm use F and f for global and local ifunc symbols])], [
+if test "${enableval}" = no; then
+ default_f_for_ifunc=0
+else
+ default_f_for_ifunc=1
+fi], [default_f_for_ifunc=0])
+
+AC_DEFINE_UNQUOTED(DEFAULT_F_FOR_IFUNC_SYMBOLS, $default_f_for_ifunc,
+ [Have nm use F and f for global and local ifunc symbols])
+
+AC_DEBUGINFOD
+
GCC_ENABLE([libctf], [yes], [], [Handle .ctf type-info sections])
if test "${enable_libctf}" = yes; then
AC_DEFINE(ENABLE_LIBCTF, 1, [Handle .ctf type-info sections])