summaryrefslogtreecommitdiff
path: root/gold/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2011-11-03 04:32:01 +0000
committerIan Lance Taylor <ian@airs.com>2011-11-03 04:32:01 +0000
commit3f3cddf146bb20f8222ce6ed8c8ffc6ee9c59124 (patch)
treeca8130f91064ed5ffc266840f2633256acae10e9 /gold/Makefile.am
parenta8e2273bba9b658132165d70edb8b47023193e82 (diff)
downloadbinutils-gdb-3f3cddf146bb20f8222ce6ed8c8ffc6ee9c59124.tar.gz
* configure.ac: Add --with-lib-path option. Define LIB_PATH and
NATIVE_LINKER. * Makefile.am (AM_CPPFLAGS): Define TOOLLIBDIR. * options.cc (General_options::finalize): Use library search path from configure script if specified. If not native and no sysroot, only search TOOLLIBDIR. * options.h (Search_directory::Search_directory): Change name to const std::string&. (General_options::add_to_library_path_with_sysroot): Change arg to const std::string&. * configure, Makefile.in, config.in: Rebuild.
Diffstat (limited to 'gold/Makefile.am')
-rw-r--r--gold/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gold/Makefile.am b/gold/Makefile.am
index c1c3588ef08..d121ac444c4 100644
--- a/gold/Makefile.am
+++ b/gold/Makefile.am
@@ -15,7 +15,7 @@ AM_CPPFLAGS = \
-I$(srcdir) -I$(srcdir)/../include -I$(srcdir)/../elfcpp \
-DLOCALEDIR="\"$(datadir)/locale\"" \
-DBINDIR="\"$(bindir)\"" -DTOOLBINDIR="\"$(tooldir)/bin\"" \
- @INCINTL@
+ -DTOOLLIBDIR="\"$(tooldir)/lib\"" @INCINTL@
LIBIBERTY = ../libiberty/libiberty.a