summaryrefslogtreecommitdiff
path: root/gprof/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-05-02 12:50:39 -0400
committerMike Frysinger <vapier@gentoo.org>2021-05-08 12:06:07 -0400
commitcf758b396026089fe2684afcc5ccd6bd3b7923c0 (patch)
tree33fabd3035b892bf46d4f565575866ce5c62bdd0 /gprof/Makefile.am
parent2faf902da5109e31ad08d84a24f827f0e6f60dc4 (diff)
downloadbinutils-gdb-cf758b396026089fe2684afcc5ccd6bd3b7923c0.tar.gz
support generating multi-html pages in parallel
Use the pattern from other projects where we generate the html pages in a dir named the same as the project. So now we have: gas/doc/gas.html - single html page gas/doc/gas/ - multiple html pages This works for projects that have a doc/ subdir already, but gprof & ld require a little tweaking since they generate their docs in their respective toplevels.
Diffstat (limited to 'gprof/Makefile.am')
-rw-r--r--gprof/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/gprof/Makefile.am b/gprof/Makefile.am
index 4ed2f29584e..5a267075383 100644
--- a/gprof/Makefile.am
+++ b/gprof/Makefile.am
@@ -103,4 +103,10 @@ gprof.1: $(srcdir)/gprof.texi config.texi
(rm -f $@.T$$$$ && exit 1)
rm -f gprof.pod
+html-local: doc/gprof/index.html
+doc/gprof/index.html: gprof.texi $(gprof_TEXINFOS)
+ $(MKDIR_P) doc
+ $(AM_V_at)$(MAKEINFOHTML) $(AM_MAKEINFOHTMLFLAGS) $(MAKEINFOFLAGS) \
+ --split=node -I$(srcdir) $(srcdir)/gprof.texi -o doc/gprof
+
MAINTAINERCLEANFILES = gprof.info