summaryrefslogtreecommitdiff
path: root/sim/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-06-06 20:35:02 -0400
committerMike Frysinger <vapier@gentoo.org>2021-06-12 20:07:57 -0400
commit04381273a9ea0cf30575d58983287cd950b3e166 (patch)
treec58e24e6afe011ffca7403f18ff41f9740dcf4a4 /sim/configure.ac
parent497a20bd3b7f7bffac5cdc7ae03e768cf92a04fd (diff)
downloadbinutils-gdb-04381273a9ea0cf30575d58983287cd950b3e166.tar.gz
sim: unify debug/stdio/trace/profile build settings
Move these options up to the common dir so we only test & export them once across all ports. The ppc code needs a little extra care with its trace settings as it's not exactly the same API as the common code. The other knobs are the same though.
Diffstat (limited to 'sim/configure.ac')
-rw-r--r--sim/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/sim/configure.ac b/sim/configure.ac
index ecf12b57a19..d8c6f2d4feb 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -99,8 +99,14 @@ if test "${enable_sim}" != no; then
fi
AM_CONDITIONAL([SIM_ENABLE_IGEN], [test "$sim_igen" = "yes"])
+dnl Standard (and optional) simulator options.
+dnl Eventually all simulators will support these.
SIM_AC_OPTION_ASSERT
+SIM_AC_OPTION_DEBUG
SIM_AC_OPTION_ENVIRONMENT
+SIM_AC_OPTION_PROFILE
+SIM_AC_OPTION_STDIO
+SIM_AC_OPTION_TRACE
AC_CONFIG_FILES([Makefile])
AC_OUTPUT