summaryrefslogtreecommitdiff
path: root/sim/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2022-11-07 21:30:10 +0700
committerMike Frysinger <vapier@gentoo.org>2022-11-07 21:51:11 +0700
commit2ba09f42f1e0a9ad44235c0cea991396b2fc520d (patch)
treecd7cef93071e77b7557e441aeeffea9f5b342fe5 /sim/configure.ac
parent200164d46732f6a2fb9d81aa9650c006db4148e6 (diff)
downloadbinutils-gdb-2ba09f42f1e0a9ad44235c0cea991396b2fc520d.tar.gz
sim: build: add a proper var for enabled arches
The install code was using $SUBDIRS to track all enabled arches. This works, but isn't great if we want to add a subdir that isn't an arch port, or as we merge the subdirs into the top-level. Create a new var explicitly to track the list of enabled arches instead.
Diffstat (limited to 'sim/configure.ac')
-rw-r--r--sim/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/sim/configure.ac b/sim/configure.ac
index 135aa2198cf..3c374377922 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -48,9 +48,14 @@ dnl used when installing files to see if they need to be suffixed.
SIM_PRIMARY_TARGET=
AC_SUBST(SIM_PRIMARY_TARGET)
+dnl Directories that we need to recurse into (i.e. add to $SUBDIRS).
SIM_SUBDIRS=
AC_SUBST(SIM_SUBDIRS)
+dnl List of enabled arch backends.
+SIM_ENABLED_ARCHES=
+AC_SUBST(SIM_ENABLED_ARCHES)
+
dnl Used by common/Make-common.in to see which configure script created it.
SIM_COMMON_BUILD_TRUE=
SIM_COMMON_BUILD_FALSE='#'
@@ -62,6 +67,7 @@ dnl Build a particular arch subdir.
dnl arg[1] is the arch subdir name.
dnl arg[2] is whether the arch has a dedicated configure script.
m4_define([SIM_BUILD_TARGET], [dnl
+ AS_VAR_APPEND([SIM_ENABLED_ARCHES], [" $1"])
m4_if($2, [true], [dnl
AC_CONFIG_SUBDIRS($1)
], [dnl