summaryrefslogtreecommitdiff
path: root/sim/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-06-18 11:12:28 -0400
committerMike Frysinger <vapier@gentoo.org>2021-06-19 16:07:31 -0400
commitbc56166f66244a9e3abc62c7bc595a6f800f23b0 (patch)
tree227192d65b33568c3864752513cfc9e1aa3f8c6c /sim/configure.ac
parentd3562f83a7b8a1ae6e333cd5561419d3da18fcb4 (diff)
downloadbinutils-gdb-bc56166f66244a9e3abc62c7bc595a6f800f23b0.tar.gz
sim: unify toolchain dependency logic
The common dir is already probing this info since it's using automake, so pass it down to the subdirs so they don't have to probe it at all.
Diffstat (limited to 'sim/configure.ac')
-rw-r--r--sim/configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/sim/configure.ac b/sim/configure.ac
index 8e9190040d4..33c7aca60f5 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -48,13 +48,20 @@ dnl used when installing files to see if they need to be suffixed.
SIM_PRIMARY_TARGET=
AC_SUBST(SIM_PRIMARY_TARGET)
-m4_define([SIM_TARGET], [
+m4_define([SIM_BUILD_TARGET], [dnl
+ AC_CONFIG_SUBDIRS($1)
+ dnl Create the depdirs for ports until we can convert them to automake.
+ AC_CONFIG_COMMANDS([depdir-$1],
+ [$SHELL $ac_aux_dir/mkinstalldirs $1/$DEPDIR],
+ [ac_aux_dir=$ac_aux_dir DEPDIR=$DEPDIR])
+])
+m4_define([SIM_TARGET], [dnl
case "${targ}" in
all|$1)
if test "${targ}" = "${target}"; then
SIM_PRIMARY_TARGET=$2
fi
- AC_CONFIG_SUBDIRS($2)
+ SIM_BUILD_TARGET($2)
$3
;;
esac
@@ -102,7 +109,7 @@ if test "${enable_sim}" != no; then
done
if test "x${enable_example_sims}" = xyes; then
- AC_CONFIG_SUBDIRS(example-synacor)
+ SIM_BUILD_TARGET([example-synacor])
fi
fi
AM_CONDITIONAL([SIM_ENABLE_IGEN], [test "$sim_igen" = "yes"])