summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2010-08-12 17:49:41 +0000
committerH.J. Lu <hjl.tools@gmail.com>2010-08-12 17:49:41 +0000
commit7277b813543b161b6e53e156f39aee262755aafe (patch)
treef46da5b9dbe932fe904456f8407d0b51927b1fd6 /bfd/Makefile.am
parent6190206b30b28f34f38f525cf39f381fadaf4bcb (diff)
downloadbinutils-redhat-7277b813543b161b6e53e156f39aee262755aafe.tar.gz
Disable -Werror on coff-tic4x.lo and coff-tic54x.lo.
2010-08-12 H.J. Lu <hongjiu.lu@intel.com> PR binutils/11909 * Makefile.am (coff-tic4x.lo): New. Disable -Werror. (coff-tic54x.lo): Likewise.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index f2ee38f460..03c5fc786a 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -960,3 +960,19 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/Makefile.in
-e "s,@report_bugs_to@,$$report_bugs_to," \
< $(srcdir)/version.h > $@; \
echo "$${bfd_soversion}" > libtool-soversion
+
+# Disable -Werror, if it has been enabled, since coffswap.h won't
+# compile with gcc 4.5 and above.
+coff-tic4x.lo: coff-tic4x.c
+@am__fastdepCC_TRUE@ $(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $< $(NO_WERROR)
+@am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $< $(NO_WERROR)
+
+coff-tic54x.lo: coff-tic54x.c
+@am__fastdepCC_TRUE@ $(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $< $(NO_WERROR)
+@am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $< $(NO_WERROR)