summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorYufeng Zhang <yufeng.zhang@arm.com>2013-06-26 10:37:45 +0000
committerYufeng Zhang <yufeng.zhang@arm.com>2013-06-26 10:37:45 +0000
commit7a82825a46bfea6cdc33b8a4907e9862d91db683 (patch)
tree1f591ccfd9c54fde4c5679efae52732d2b1d83b0 /bfd/Makefile.am
parent558d0f77497d5cc676aacd3f355dc9b52c84617d (diff)
downloadbinutils-redhat-7a82825a46bfea6cdc33b8a4907e9862d91db683.tar.gz
[AArch64, ILP32] 1/6 Rename elf64-aarch64.c to elfnn-aarch64.c
bfd/ * Makefile.am (BFD64_BACKENDS_CFILES): Remove elf64-aarch64.c. (BUILD_CFILES): Add elf64-aarch64.c. (elf64-aarch64.c): New rule for generating from elfnn-aarch64.c. * Makefile.in: Re-generated. * elf64-aarch64.c: Rename to ... * elfnn-aarch64.c: ... this.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index cacf7a384a..5ed9bc76e0 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -678,7 +678,6 @@ BFD64_BACKENDS = \
vms-alpha.lo
BFD64_BACKENDS_CFILES = \
- elf64-aarch64.c \
aix5ppc-core.c \
aout64.c \
coff-alpha.c \
@@ -764,6 +763,7 @@ SOURCE_CFILES = \
$(OPTIONAL_BACKENDS_CFILES)
BUILD_CFILES = \
+ elf64-aarch64.c \
elf32-ia64.c elf64-ia64.c peigen.c pepigen.c pex64igen.c
CFILES = $(SOURCE_CFILES) $(BUILD_CFILES)
@@ -912,6 +912,11 @@ elf64-target.h : elfxx-target.h
sed -e s/NN/64/g < $(srcdir)/elfxx-target.h > elf64-target.new
mv -f elf64-target.new elf64-target.h
+elf64-aarch64.c : elfnn-aarch64.c
+ rm -f elf64-aarch64.c
+ sed -e s/NN/64/g < $(srcdir)/elfnn-aarch64.c > elf64-aarch64.new
+ mv -f elf64-aarch64.new elf64-aarch64.c
+
elf32-ia64.c : elfnn-ia64.c
rm -f elf32-ia64.c
sed -e s/NN/32/g < $(srcdir)/elfnn-ia64.c > elf32-ia64.new