summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorH.J. Lu <hjl@lucon.org>2007-01-12 04:04:08 +0000
committerH.J. Lu <hjl@lucon.org>2007-01-12 04:04:08 +0000
commit82d6a00d482bde567c9ddadf86a75228e6da3389 (patch)
treec125730a8e67558c5875cdbab190308ede03f935 /bfd/Makefile.am
parentbf734133313151fa1307846ff33e664b33297f89 (diff)
downloadbinutils-redhat-82d6a00d482bde567c9ddadf86a75228e6da3389.tar.gz
2076-01-11 H.J. Lu <hongjiu.lu@intel.com>
PR binutils/3631 * Makefile.am (OFILES): Add @bfd64_libs@. (libbfd_la_SOURCES): Remove $(BFD64_LIBS_CFILES). * Makefile.in: Regenerated. * configure.in (bfd_libs): Replaced by ... (bfd64_libs): This. * configure: Regenerated.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 435b30b3c3..1d7f8e81ff 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -717,7 +717,8 @@ install-html-recursive:
# BFD_BACKENDS Routines the configured targets need.
# BFD_MACHINES Architecture-specific routines the configured targets need.
# COREFILE Core file routines for a native configuration
-OFILES = $(BFD_BACKENDS) $(BFD_MACHINES) @COREFILE@
+# bfd64_libs Routines for 64bit support
+OFILES = $(BFD_BACKENDS) $(BFD_MACHINES) @COREFILE@ @bfd64_libs@
stamp-ofiles: Makefile
rm -f tofiles
@@ -734,7 +735,9 @@ stamp-ofiles: Makefile
ofiles: stamp-ofiles ; @true
-libbfd_la_SOURCES = $(BFD32_LIBS_CFILES) $(BFD64_LIBS_CFILES)
+# Since BFD64_LIBS is optional and we can't have substitution in
+# libbfd_la_SOURCES, we put BFD64_LIBS in OFILES instead.
+libbfd_la_SOURCES = $(BFD32_LIBS_CFILES)
libbfd_la_DEPENDENCIES = $(OFILES) ofiles
libbfd_la_LIBADD = `cat ofiles` @WIN32LIBADD@
libbfd_la_LDFLAGS = -release $(VERSION) @WIN32LDFLAGS@