summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-04 13:00:35 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-04 13:00:35 +0000
commit9f77ec1bef794b1ec805353974fd14144aad7643 (patch)
tree2f940aa09aeea83f531062b1bf216eb723bf2ea0 /bfd/Makefile.am
parent871fa7ee4036d66ef6f4f0dc8e4cb40fba8b300e (diff)
downloadbinutils-redhat-9f77ec1bef794b1ec805353974fd14144aad7643.tar.gz
bfd: install plugin-api.h as needed
Since people need plugin-api.h in order to build linker plugins, install the header with the other library headers when plugin support is enabled. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index da14d57fda..9c454cc1c8 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -23,6 +23,7 @@ else !INSTALL_LIBBFD
# Empty these so that the respective installation directories will not be created.
bfdlibdir =
bfdincludedir =
+bfdinclude_HEADERS =
rpath_bfdlibdir = @bfdlibdir@
noinst_LTLIBRARIES = libbfd.la
libbfd_la_LDFLAGS += -rpath $(rpath_bfdlibdir)
@@ -33,6 +34,7 @@ NO_WERROR = @NO_WERROR@
AM_CFLAGS = $(WARN_CFLAGS)
AM_CPPFLAGS = -DBINDIR='"$(bindir)"'
if PLUGINS
+bfdinclude_HEADERS += $(INCDIR)/plugin-api.h
LIBDL = -ldl
endif