summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorTristan Gingold <gingold@adacore.com>2011-05-25 12:02:11 +0000
committerTristan Gingold <gingold@adacore.com>2011-05-25 12:02:11 +0000
commitf1eb73e130a7b851ef380fe12c0021213ed9913d (patch)
treebbf9676ca073e0a6476d6b04d67eaf449bf922ea /bfd/Makefile.am
parent661d223149c6aeaab82b10527197b3cab11ea556 (diff)
downloadbinutils-redhat-f1eb73e130a7b851ef380fe12c0021213ed9913d.tar.gz
2011-05-25 Tristan Gingold <gingold@adacore.com>
* configure.in (bfd_elf32_ia64_big_vec, bfd_elf32_ia64_hpux_big_vec) (bfd_elf64_ia64_big_vec, bfd_elf64_ia64_hpux_big_vec) (bfd_elf64_ia64_little_vec, bfd_elf64_ia64_vms_vec): Add elfxx-ia64.lo * Makefile.am (BFD64_BACKENDS): Add elfxx-ia64.lo (BFD64_BACKENDS_CFILES): Add elfxx-ia64.c (elf32-ia64.c): Created from elfnn-ia64.c (elf64-ia64.c): Likewise. * elfxx-ia64.h: New file. * elfxx-ia64.c: Split with elfnn-ia64.c. Keep only the following functions.Includes elfxx-ia64.h. (elfNN_ia64_reloc): Renames to ia64_elf_reloc. Adjust error message. (IA64_HOWTO): Adjust. (lookup_howto): Renames to ia64_elf_lookup_howto. Make it public. (elfNN_ia64_reloc_type_lookup): Renames to ia64_elf_reloc_type_lookup. Make it public. Adjust calls. (elfNN_ia64_reloc_name_lookup): Renames to ia64_elf_reloc_name_lookup. Make it public. (elfNN_ia64_relax_br): Renames to ia64_elf_relax_br. Make it public. (elfNN_ia64_relax_brl): Renames to ia64_elf_relax_brl. Make it public. (elfNN_ia64_relax_ldxmov): Renames to ia64_elf_relax_ldxmov. Move it and make it public. Move prototype to elfxx-ia64.h (elfNN_ia64_install_value): Renames to ia64_elf_install_value. Move prototype to elfxx-ia64.h * elfnn-ia64.c: New file, split from elfxx-ia64.c. (elfNN_ia64_info_to_howto): Adjust calls. (elfNN_ia64_relax_section): Adjust calls. (count_dyn_reloc): Fix typo. (elfNN_ia64_relocate_section): Adjust calls. (elfNN_ia64_finish_dynamic_symbol): Likewise. (bfd_elfNN_bfd_reloc_type_lookup) (bfd_elfNN_bfd_reloc_name_lookup): Adjust macros.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index c27c16d087..98772f0206 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -605,6 +605,7 @@ BFD64_BACKENDS = \
elf64-x86-64.lo \
elf64.lo \
elfn32-mips.lo \
+ elfxx-ia64.lo \
mach-o-x86-64.lo \
mmo.lo \
nlm32-alpha.lo \
@@ -637,6 +638,7 @@ BFD64_BACKENDS_CFILES = \
elf64-x86-64.c \
elf64.c \
elfn32-mips.c \
+ elfxx-ia64.c \
mach-o-x86-64.c \
mmo.c \
nlm32-alpha.c \
@@ -845,14 +847,14 @@ elf64-target.h : elfxx-target.h
sed -e s/NN/64/g < $(srcdir)/elfxx-target.h > elf64-target.new
mv -f elf64-target.new elf64-target.h
-elf32-ia64.c : elfxx-ia64.c
+elf32-ia64.c : elfnn-ia64.c
rm -f elf32-ia64.c
- sed -e s/NN/32/g < $(srcdir)/elfxx-ia64.c > elf32-ia64.new
+ sed -e s/NN/32/g < $(srcdir)/elfnn-ia64.c > elf32-ia64.new
mv -f elf32-ia64.new elf32-ia64.c
-elf64-ia64.c : elfxx-ia64.c
+elf64-ia64.c : elfnn-ia64.c
rm -f elf64-ia64.c
- sed -e s/NN/64/g < $(srcdir)/elfxx-ia64.c > elf64-ia64.new
+ sed -e s/NN/64/g < $(srcdir)/elfnn-ia64.c > elf64-ia64.new
mv -f elf64-ia64.new elf64-ia64.c
peigen.c : peXXigen.c