summaryrefslogtreecommitdiff
path: root/binutils/Makefile.am
diff options
context:
space:
mode:
authorDaniel Jacobowitz <dan@debian.org>2007-03-01 12:35:40 +0000
committerDaniel Jacobowitz <dan@debian.org>2007-03-01 12:35:40 +0000
commit11dd46563554b82900d71bb4d03a98f72a83f968 (patch)
tree5418a6c3eaae0ee7c9558392cb4ec87c7a887a78 /binutils/Makefile.am
parent10675f54b233d6291a6d272d9d772d3a85c437cc (diff)
downloadbinutils-redhat-11dd46563554b82900d71bb4d03a98f72a83f968.tar.gz
* Makefile.am (install-exec-local): Depend on $(noinst_PROGRAMS).
Adjust $(EXEEXT) handling for $(RENAMED_PROGS). * Makefile.in, doc/Makefile.in: Regenerate.
Diffstat (limited to 'binutils/Makefile.am')
-rw-r--r--binutils/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/binutils/Makefile.am b/binutils/Makefile.am
index 52fbca3fd3..0378a01d1c 100644
--- a/binutils/Makefile.am
+++ b/binutils/Makefile.am
@@ -407,11 +407,11 @@ CLEANFILES = dep.sed DEP DEPA DEP1 DEP2
.PHONY: install-exec-local
-install-exec-local: install-binPROGRAMS $(bin_PROGRAMS) $(RENAMED_PROGS)
+install-exec-local: install-binPROGRAMS $(bin_PROGRAMS) $(noinst_PROGRAMS)
@list='$(RENAMED_PROGS)'; for p in $$list; do \
- if test -f $$p; then \
- echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(bindir)/`echo $$p|sed -e 's/$(EXEEXT)$$//' -e 's/-new//' -e 's/cxxfilt/$(DEMANGLER_NAME)/'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed -e 's/$(EXEEXT)$$//' -e 's/-new//' -e 's/cxxfilt/$(DEMANGLER_NAME)/'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ if test -f $$p$(EXEEXT); then \
+ echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p$(EXEEXT) $(bindir)/`echo $$p|sed -e 's/-new//' -e 's/cxxfilt/$(DEMANGLER_NAME)/'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p$(EXEEXT) $(DESTDIR)$(bindir)/`echo $$p|sed -e 's/-new//' -e 's/cxxfilt/$(DEMANGLER_NAME)/'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
else :; fi; \
done
$(mkinstalldirs) $(DESTDIR)$(tooldir)/bin