summaryrefslogtreecommitdiff
path: root/binutils/Makefile.am
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2012-11-06 23:45:42 +0000
committerH.J. Lu <hjl.tools@gmail.com>2012-11-06 23:45:42 +0000
commit2e1425ec997c26f22a29dcd20772895f532b0afb (patch)
tree32b7446b5d8f20ce80caee660306ff7cbeb71bf8 /binutils/Makefile.am
parent9372fef99b6b0f1df1659d1d36222af8ef42f77e (diff)
downloadbinutils-redhat-2e1425ec997c26f22a29dcd20772895f532b0afb.tar.gz
Add a testcase for PR binutils/14567
binutils/ PR binutils/14567 * Makefile.am (BFDTEST2_PROG): New. (bfdtest2_DEPENDENCIES): Likewise. (TEST_PROGS): Add $(BFDTEST2_PROG). * Makefile.in: Regenerated. * bfdtest2.c: New file. binutils/testsuite/ PR binutils/14567 * binutils-all/ar.exp (bfdtest1): Removed. (long_filenames): Take bfdtests. (thin_archive): Likewise. (thin_archive_with_nested): Likewise. (bfdtests): New. Pass $bfdtests to long_filenames, thin_archive and thin_archive_with_nested.
Diffstat (limited to 'binutils/Makefile.am')
-rw-r--r--binutils/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/binutils/Makefile.am b/binutils/Makefile.am
index f16de99087..be6e832500 100644
--- a/binutils/Makefile.am
+++ b/binutils/Makefile.am
@@ -67,8 +67,9 @@ EXTRA_SCRIPTS = embedspu
## Test programs.
BFDTEST1_PROG = bfdtest1
+BFDTEST2_PROG = bfdtest2
-TEST_PROGS = $(BFDTEST1_PROG)
+TEST_PROGS = $(BFDTEST1_PROG) $(BFDTEST2_PROG)
## We need a special rule to install the programs which are built with
## -new, and to rename cxxfilt to c++filt.
@@ -200,6 +201,7 @@ readelf_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY)
elfedit_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY)
dllwrap_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY)
bfdtest1_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY) $(BFDLIB)
+bfdtest2_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY) $(BFDLIB)
LDADD = $(BFDLIB) $(LIBIBERTY) $(LIBINTL)