summaryrefslogtreecommitdiff
path: root/binutils/Makefile.am
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2007-08-30 13:47:35 +0000
committerNick Clifton <nickc@redhat.com>2007-08-30 13:47:35 +0000
commit584e49798ccafec325e2953b61574360d25de27b (patch)
treee492486cb832d2c5d52421a2a961fb30f12c0e37 /binutils/Makefile.am
parentf118e1e6952892e73da92d5696b42ca2eea6c662 (diff)
downloadbinutils-redhat-584e49798ccafec325e2953b61574360d25de27b.tar.gz
* readelf.c (dump_type): New type used to classify the kinds of dump requested by the user.
(dump_sects, cmdline_dump_sects): Use the new type. (options): Add --string-dump option. (request_dump): Rename to request_dump_bynumber. Use dump_type. (request_dump_byname): Use dump_type. (parse_args): Parse --string-dump option. (process_section_headers): Fix calls to request_dump. (initialise_dumps_byname): Likewise. (dump_section): Rename to dump_section_as_bytes. (dump_section_as_strings): New function. Display the contents of a section as printable strings. (process_section_contents): String dump the section if requested. (process_object): Use dump_type. (main): Likewise. * Makefile.am: Add dependency for readelf.c on safe-ctype.h. * Makefile.in: Regenerate. * NEWS: Mention the new feature. * doc/binutils.texi: Document the new feature. * testsuite/binutils-all/dumptest.s: New test file. * testsuite/binutils-all/readelf.exp: Add test of readelf's -p switch.
Diffstat (limited to 'binutils/Makefile.am')
-rw-r--r--binutils/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/binutils/Makefile.am b/binutils/Makefile.am
index 047622cb5e..9590b18d4c 100644
--- a/binutils/Makefile.am
+++ b/binutils/Makefile.am
@@ -593,7 +593,7 @@ readelf.o: readelf.c sysdep.h $(INCDIR)/ansidecl.h \
$(INCDIR)/elf/spu.h $(INCDIR)/elf/v850.h $(INCDIR)/elf/vax.h \
$(INCDIR)/elf/x86-64.h $(INCDIR)/elf/xstormy16.h $(INCDIR)/elf/xtensa.h \
$(INCDIR)/aout/ar.h $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
- unwind-ia64.h
+ unwind-ia64.h $(INCDIR)/safe-ctype.h
rename.o: rename.c sysdep.h $(INCDIR)/ansidecl.h ../bfd/bfdver.h \
config.h $(INCDIR)/fopen-same.h ../bfd/bfd.h $(INCDIR)/ansidecl.h \
$(INCDIR)/symcat.h bucomm.h