summaryrefslogtreecommitdiff
path: root/binutils/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2011-08-08 00:27:14 +0000
committerAlan Modra <amodra@bigpond.net.au>2011-08-08 00:27:14 +0000
commit59afcd017f53d33b59397ae0c49711f9baaa1911 (patch)
tree31d445ebfbbbe63f528d14171eb50c58ab65c85e /binutils/Makefile.am
parentcb9b882fd416cfa767346ca54d25f0e78b4a8894 (diff)
downloadbinutils-redhat-59afcd017f53d33b59397ae0c49711f9baaa1911.tar.gz
PR binutils/12964
* Makefile.am (embedspu): Use awk rather than sed. * Makefile.in: Regenerate.
Diffstat (limited to 'binutils/Makefile.am')
-rw-r--r--binutils/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/binutils/Makefile.am b/binutils/Makefile.am
index 76fc50a1a0..bbe58e2132 100644
--- a/binutils/Makefile.am
+++ b/binutils/Makefile.am
@@ -288,7 +288,7 @@ bin2c$(EXEEXT_FOR_BUILD): bin2c.c
$(CC_FOR_BUILD) -o $@ $(AM_CPPFLAGS) $(AM_CFLAGS) $(CFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) $(srcdir)/bin2c.c
embedspu: embedspu.sh Makefile
- sed "/^program_transform_name=/cprogram_transform_name=$(program_transform_name)" < $< > $@
+ awk '/^program_transform_name=/ {print "program_transform_name=\"$(program_transform_name)\""; next} {print}' < $< > $@
chmod a+x $@
# We need these for parallel make.