summaryrefslogtreecommitdiff
path: root/binutils/Makefile.am
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2010-01-06 16:52:13 +0000
committerH.J. Lu <hjl.tools@gmail.com>2010-01-06 16:52:13 +0000
commitfabf5c5416235b74ba75eeab4dba0e00c7ded721 (patch)
tree4dac3fd50e1f3d18fef37be663b9ffb6f17350e2 /binutils/Makefile.am
parentfed9df78d4ddc60fafdad030f0219ecc36682a7c (diff)
downloadbinutils-redhat-fabf5c5416235b74ba75eeab4dba0e00c7ded721.tar.gz
Add elfedit
binutils/ 2010-01-06 H.J. Lu <hongjiu.lu@intel.com> PR binutils/11131 * Makefile.am (ELFEDIT_PROG): New. (bin_PROGRAMS): Add $(ELFEDIT_PROG). (CFILES): Add elfedit.c. (elfedit_DEPENDENCIES): New. (elfedit_SOURCES): Likewise. (elfedit_LDADD): Likewise. * Makefile.in: Regenerated. * elfedit.c: New. * doc/binutils.texi: Document elfedit. * doc/Makefile.am (man_MANS): Add elfedit.1. (elfedit.1): New. * doc/Makefile.in: Regenerated. binutils/testsuite/ 2010-01-06 H.J. Lu <hongjiu.lu@intel.com> PR binutils/11131 * binutils-all/elfedit-1.d: New. * binutils-all/elfedit.exp: Likewise. * config/default.exp (ELFEDIT): New. Set if it doesn't exist. (ELFEDITFLAGS): Likewise. * lib/utils-lib.exp (run_dump_test): Support elfedit.
Diffstat (limited to 'binutils/Makefile.am')
-rw-r--r--binutils/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/binutils/Makefile.am b/binutils/Makefile.am
index db7a77352a..873e568434 100644
--- a/binutils/Makefile.am
+++ b/binutils/Makefile.am
@@ -39,6 +39,8 @@ STRINGS_PROG=strings
READELF_PROG=readelf
+ELFEDIT_PROG=elfedit
+
# These should all be the same program too.
SIZE_PROG=size
NM_PROG=nm-new
@@ -58,7 +60,7 @@ DLLWRAP_PROG=dllwrap
SRCONV_PROG=srconv$(EXEEXT) sysdump$(EXEEXT) coffdump$(EXEEXT)
-bin_PROGRAMS = $(SIZE_PROG) $(OBJDUMP_PROG) $(AR_PROG) $(STRINGS_PROG) $(RANLIB_PROG) $(OBJCOPY_PROG) @BUILD_NLMCONV@ @BUILD_SRCONV@ @BUILD_DLLTOOL@ @BUILD_WINDRES@ @BUILD_WINDMC@ $(ADDR2LINE_PROG) $(READELF_PROG) @BUILD_DLLWRAP@ @BUILD_INSTALL_MISC@
+bin_PROGRAMS = $(SIZE_PROG) $(OBJDUMP_PROG) $(AR_PROG) $(STRINGS_PROG) $(RANLIB_PROG) $(OBJCOPY_PROG) @BUILD_NLMCONV@ @BUILD_SRCONV@ @BUILD_DLLTOOL@ @BUILD_WINDRES@ @BUILD_WINDMC@ $(ADDR2LINE_PROG) $(READELF_PROG) $(ELFEDIT_PROG) @BUILD_DLLWRAP@ @BUILD_INSTALL_MISC@
## We need a special rule to install the programs which are built with
## -new, and to rename cxxfilt to c++filt.
@@ -100,7 +102,7 @@ CFILES = \
rclex.c rdcoff.c rddbg.c readelf.c rename.c \
resbin.c rescoff.c resrc.c resres.c \
size.c srconv.c stabs.c strings.c sysdump.c \
- unwind-ia64.c version.c \
+ unwind-ia64.c elfedit.c version.c \
windres.c winduni.c wrstabs.c \
windmc.c mclex.c
@@ -179,6 +181,7 @@ windres_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY) $(BFDLIB)
windmc_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY) $(BFDLIB)
addr2line_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY) $(BFDLIB)
readelf_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY)
+elfedit_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY)
dllwrap_DEPENDENCIES = $(LIBINTL_DEP) $(LIBIBERTY)
LDADD = $(BFDLIB) $(LIBIBERTY) $(LIBINTL)
@@ -192,6 +195,9 @@ strings_SOURCES = strings.c $(BULIBS)
readelf_SOURCES = readelf.c version.c unwind-ia64.c dwarf.c
readelf_LDADD = $(LIBINTL) $(LIBIBERTY)
+elfedit_SOURCES = elfedit.c version.c
+elfedit_LDADD = $(LIBINTL) $(LIBIBERTY)
+
strip_new_SOURCES = objcopy.c is-strip.c rename.c $(WRITE_DEBUG_SRCS) $(BULIBS)
nm_new_SOURCES = nm.c $(BULIBS)