summaryrefslogtreecommitdiff
path: root/binutils/configure.in
diff options
context:
space:
mode:
authorZack Weinberg <zackw@panix.com>2002-09-17 07:09:47 +0000
committerZack Weinberg <zackw@panix.com>2002-09-17 07:09:47 +0000
commit538868c15e042c9740400206704097b8f45c1ee1 (patch)
tree6ea0b8437b239911216e1d2a5beb7503c70910b7 /binutils/configure.in
parent690d0d26bfef4f2cef6df9bf30662a46bbde1816 (diff)
downloadbinutils-redhat-538868c15e042c9740400206704097b8f45c1ee1.tar.gz
binutils:
* Makefile.am (CFILES): Add cxxfilt.c. (cxxfilt_SOURCES): Now just cxxfilt.c $(BULIBS). (cxxfilt_LDADD): Delete. Remove all references to underscore.c. Regen dependencies. * configure.in: Define TARGET_PREPENDS_UNDERSCORE in config.h from $UNDERSCORE, rather than AC_SUBSTing it. * binutils/cxxfilt.c: Moved here from gcc/cp, minor adjustments to fit into binutils framework. * configure, config.in, Makefile.in, doc/Makefile.in: Regenerate. gcc/cp: * Make-lang.in: Remove all references to the demangler. * cxxfilt.c: Moved to binutils.
Diffstat (limited to 'binutils/configure.in')
-rw-r--r--binutils/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/binutils/configure.in b/binutils/configure.in
index f2a048263a..6f6cbd0244 100644
--- a/binutils/configure.in
+++ b/binutils/configure.in
@@ -311,7 +311,8 @@ if test "x$targ_underscore" = "xyes"; then
else
UNDERSCORE=0
fi
-AC_SUBST(UNDERSCORE)
+AC_DEFINE_UNQUOTED(TARGET_PREPENDS_UNDERSCORE, $UNDERSCORE,
+ [Define to 1 if user symbol names have a leading underscore, 0 if not.])
# Emulation
for targ_alias in `echo $target_alias $enable_targets | sed 's/,/ /g'`