summaryrefslogtreecommitdiff
path: root/binutils/doc/Makefile.am
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2007-06-19 13:24:33 +0000
committerNick Clifton <nickc@redhat.com>2007-06-19 13:24:33 +0000
commitc6a8fb89efd2a586d6ce44fae92d32571c624843 (patch)
tree92eb2c54df02361f429ab7ac65a9fa8401188426 /binutils/doc/Makefile.am
parent668b8cbeee993cc49b28450386432f307345b7fd (diff)
downloadbinutils-redhat-c6a8fb89efd2a586d6ce44fae92d32571c624843.tar.gz
* Makefile.am: Add windmc tool.
* Makefile.in: Regenerate. * configure.in: Add windmc tool. * configure: Regenerate. * mclex.c: New. * mcparse.y: New. * windmc.c: New. * windmc.h: New. * doc/Makefile.am: Add windmc tool. * doc/Makefile.in: Regenerate. * doc/binutils.texi: Add windmc documentation. * NEWS: Mention new tool.
Diffstat (limited to 'binutils/doc/Makefile.am')
-rw-r--r--binutils/doc/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/binutils/doc/Makefile.am b/binutils/doc/Makefile.am
index 5d8520cf52..ceeda41b00 100644
--- a/binutils/doc/Makefile.am
+++ b/binutils/doc/Makefile.am
@@ -28,6 +28,7 @@ man_MANS = \
strings.1 \
strip.1 \
windres.1 \
+ windmc.1 \
$(DEMANGLER_NAME).1
info_TEXINFOS = binutils.texi
@@ -130,6 +131,13 @@ windres.1: $(binutils_TEXI) $(binutils_TEXINFOS)
mv -f $@.T$$$$ $@) || (rm -f $@.T$$$$ && exit 1)
rm -f windres.pod
+windmc.1: $(binutils_TEXI) $(binutils_TEXINFOS)
+ touch $@
+ -$(TEXI2POD) $(MANCONF) -Dwindmc < $(binutils_TEXI) > windmc.pod
+ -($(POD2MAN) windmc.pod | sed -e '/^.if n .na/d' > $@.T$$$$ && \
+ mv -f $@.T$$$$ $@) || (rm -f $@.T$$$$ && exit 1)
+ rm -f windmc.pod
+
cxxfilt.man: $(binutils_TEXI) $(binutils_TEXINFOS)
touch $@
-$(TEXI2POD) $(MANCONF) -Dcxxfilt < $(binutils_TEXI) > $(DEMANGLER_NAME).pod