summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Botcazou <ebotcazou@libertysurf.fr>2012-10-23 23:02:33 +0000
committerEric Botcazou <ebotcazou@libertysurf.fr>2012-10-23 23:02:33 +0000
commit1d7f078ec0360a038b2e16881bec46d0d0560af7 (patch)
tree5adaf7006bc5b6b7f1f9f23ae56be6e618a67556 /configure.ac
parent289dd850f6a6fc77b6754bd973a1457caf3b5c33 (diff)
downloadbinutils-redhat-1d7f078ec0360a038b2e16881bec46d0d0560af7.tar.gz
PR bootstrap/54820
* configure.ac (have_static_libs): Force 'no' for GCC version < 4.5. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 958eadd5e7..c6665a1f33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1190,7 +1190,11 @@ if test "$GCC" = yes; then
LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
AC_MSG_CHECKING([whether g++ accepts -static-libstdc++ -static-libgcc])
AC_LANG_PUSH(C++)
- AC_LINK_IFELSE([int main() {}],
+ AC_LINK_IFELSE([
+#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
+#error -static-libstdc++ not implemented
+#endif
+int main() {}],
[AC_MSG_RESULT([yes]); have_static_libs=yes],
[AC_MSG_RESULT([no])])
AC_LANG_POP(C++)