summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Stump <mrs@apple.com>2013-07-10 20:55:59 +0000
committerMike Stump <mrs@apple.com>2013-07-10 20:55:59 +0000
commit730e9071ef826206a9ae81994fdf6be82661fe3e (patch)
tree2744ee7a2286c2c4d75f8adf6cab9677e550e18c /configure.ac
parentdf198adbfb6696d9732a11c23a3155fc783857aa (diff)
downloadbinutils-redhat-730e9071ef826206a9ae81994fdf6be82661fe3e.tar.gz
2013-07-10 Jack Howarth <howarth@bromo.med.uc.edu>
PR target/57792 * configure.ac: Use --with-sysroot=\"`xcrun --show-sdk-path`\" on darwin13 and later. * configure: Regenerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 226239b77d..d4dc10bd72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2854,6 +2854,13 @@ if test x${is_cross_compiler} = xyes ; then
target_configargs="--with-cross-host=${host_noncanonical} ${target_configargs}"
fi
+# Pass --with-sysroot on darwin without SDK in /
+case "${target}" in
+ x86_64-*-darwin1[[3-9]]*)
+ host_configargs="--with-sysroot=\"`xcrun --show-sdk-path`\" ${host_configargs}"
+ ;;
+esac
+
# Default to --enable-multilib.
if test x${enable_multilib} = x ; then
target_configargs="--enable-multilib ${target_configargs}"