summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Benedict Glaw <jbglaw@lug-owl.de>2013-01-15 21:46:57 +0000
committerJan-Benedict Glaw <jbglaw@lug-owl.de>2013-01-15 21:46:57 +0000
commit73a339dd521e02325b8c919f78dec8c2693cfbba (patch)
treef2ca6676b962d18fe77c1d92bb8ae0b8c0b7fd7c /configure.ac
parente1f10ba82417195f78cfef785abfad1be70bd7a4 (diff)
downloadbinutils-redhat-73a339dd521e02325b8c919f78dec8c2693cfbba.tar.gz
* configure.ac: Sync with GCC repo.
* configure: Ditto. * Makefile.def: Ditto. * Makefile.in: Ditto.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 02720ee1b1..739cdc786c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1606,8 +1606,11 @@ if test "x$with_isl" != "xno" &&
dnl Provide configure switches and initialize islinc & isllibs
dnl with user input.
ISL_INIT_FLAGS
- dnl The minimal version of ISL required for Graphite.
+ dnl The versions of ISL that work for Graphite
ISL_CHECK_VERSION(0,10)
+ if test "${gcc_cv_isl}" = no ; then
+ ISL_CHECK_VERSION(0,11)
+ fi
dnl Only execute fail-action, if ISL has been requested.
ISL_IF_FAILED([
AC_MSG_ERROR([Unable to find a usable ISL. See config.log for details.])])
@@ -1617,11 +1620,11 @@ if test "x$with_isl" != "xno" &&
dnl Provide configure switches and initialize clooginc & clooglibs
dnl with user input.
CLOOG_INIT_FLAGS
- dnl The minimal version of CLooG required for Graphite.
- dnl
- dnl If we use CLooG-Legacy, the provided version information is
- dnl ignored.
+ dnl The versions of CLooG that work for Graphite.
CLOOG_CHECK_VERSION(0,17,0)
+ if test "${gcc_cv_cloog}" = no ; then
+ CLOOG_CHECK_VERSION(0,18,0)
+ fi
dnl Only execute fail-action, if CLooG has been requested.
CLOOG_IF_FAILED([