summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwalt <walt>2012-09-15 17:11:26 +0000
committerwalt <walt>2012-09-15 17:11:26 +0000
commit7be04644de6cbfe11cb6f18286141e5183c84eae (patch)
tree86a3faaa2320adbe89dda4718c0bc1fbc47e4c3f /configure.ac
parent4897166f101ebf48af998d189cc241811fda81a5 (diff)
downloadbinutils-redhat-7be04644de6cbfe11cb6f18286141e5183c84eae.tar.gz
Add support for tilegx in gold.
* configure.ac (ENABLE_GOLD): support tilegx* * configure: rebuild elfcpp: * tilegx.h: New file. * elfcpp.h: add EM_TILEGX. gold: * tilegx.cc: New file. * Makefile.am (TARGETSOURCES): Add tilegx.cc (ALL_TARGETOBJS): Add tilegx.$(OBJEXT) * configure.tgt: Add entries for tilegx*. * configure.ac: Likewise. * Makefile.in: Rebuild. * configure: Likewise. * testsuite/icf_safe_test.sh (arch_specific_safe_fold): Handle tilegx.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index aaf3df371b..df56cd1c64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,7 +328,7 @@ case "${ENABLE_GOLD}" in
if test "$is_elf" = "yes"; then
# Check for target supported by gold.
case "${target}" in
- i?86-*-* | x86_64-*-* | sparc*-*-* | powerpc*-*-* | arm*-*-*)
+ i?86-*-* | x86_64-*-* | sparc*-*-* | powerpc*-*-* | arm*-*-* | tilegx*-*-*)
configdirs="$configdirs gold"
if test x${ENABLE_GOLD} = xdefault; then
default_ld=gold