summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2012-06-28 11:50:52 +0000
committerAlexandre Oliva <aoliva@redhat.com>2012-06-28 11:50:52 +0000
commit7f4ea1ce0792120b9d8f1ec59df7692ce7ad9b71 (patch)
tree3bbdc2ff7df5e02a6c93b7115802e88f5ef94ccf /configure.ac
parent5330d3b4e456d2a09eda622db086940329993e7d (diff)
downloadbinutils-redhat-7f4ea1ce0792120b9d8f1ec59df7692ce7ad9b71.tar.gz
* configure.ac (CFLAGS_FOR_TARGET, CXXFLAGS_FOR_TARGET): Make sure
they contain -O2. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 224127c1d9..5efb4a32f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2125,11 +2125,11 @@ if test "x$CFLAGS_FOR_TARGET" = x; then
CFLAGS_FOR_TARGET=$CFLAGS
case " $CFLAGS " in
*" -O2 "*) ;;
- *) CFLAGS_FOR_TARGET="-O2 $CFLAGS" ;;
+ *) CFLAGS_FOR_TARGET="-O2 $CFLAGS_FOR_TARGET" ;;
esac
case " $CFLAGS " in
*" -g "* | *" -g3 "*) ;;
- *) CFLAGS_FOR_TARGET="-g $CFLAGS" ;;
+ *) CFLAGS_FOR_TARGET="-g $CFLAGS_FOR_TARGET" ;;
esac
fi
AC_SUBST(CFLAGS_FOR_TARGET)
@@ -2138,11 +2138,11 @@ if test "x$CXXFLAGS_FOR_TARGET" = x; then
CXXFLAGS_FOR_TARGET=$CXXFLAGS
case " $CXXFLAGS " in
*" -O2 "*) ;;
- *) CXXFLAGS_FOR_TARGET="-O2 $CXXFLAGS" ;;
+ *) CXXFLAGS_FOR_TARGET="-O2 $CXXFLAGS_FOR_TARGET" ;;
esac
case " $CXXFLAGS " in
*" -g "* | *" -g3 "*) ;;
- *) CXXFLAGS_FOR_TARGET="-g $CXXFLAGS" ;;
+ *) CXXFLAGS_FOR_TARGET="-g $CXXFLAGS_FOR_TARGET" ;;
esac
fi
AC_SUBST(CXXFLAGS_FOR_TARGET)