summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2012-12-12 13:52:55 +0000
committerH.J. Lu <hjl.tools@gmail.com>2012-12-12 13:52:55 +0000
commit8f744e9bc8e672281a2387affe12486a89a47d07 (patch)
tree23f732f3b39816c6a445e01f1e4294075ee1892a /configure.ac
parentcd71cc9b9a4097c492cc7417f2e320593675a68a (diff)
downloadbinutils-redhat-8f744e9bc8e672281a2387affe12486a89a47d07.tar.gz
Add --with-build-config=bootstrap-asan support
* Makefile.def (target_modules): Add bootstrap=true and raw_cxx=true to libsanitizer. * configure.ac (bootstrap_target_libs): Add libsanitizer. * Makefile.in: Regenerated. * configure: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49f4f5dae8..a92ff3af8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2433,6 +2433,11 @@ if echo " ${target_configdirs} " | grep " libgomp " > /dev/null 2>&1 ; then
bootstrap_target_libs=${bootstrap_target_libs}target-libgomp,
fi
+# If we are building libsanitizer, bootstrap it.
+if echo " ${target_configdirs} " | grep " libsanitizer " > /dev/null 2>&1 ; then
+ bootstrap_target_libs=${bootstrap_target_libs}target-libsanitizer,
+fi
+
# Determine whether gdb needs tk/tcl or not.
# Use 'maybe' since enable_gdbtk might be true even if tk isn't available
# and in that case we want gdb to be built without tk. Ugh!