summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2011-04-06 12:21:20 +0000
committerJoseph Myers <joseph@codesourcery.com>2011-04-06 12:21:20 +0000
commit9bbeae8fb85fc8e83c7684dcbc647faed08c3e27 (patch)
treed951843caa290c145677e8c17d75d4b4c0fc1769 /configure.ac
parenta459260877fa20df83da230ce1cecefe8f91e080 (diff)
downloadbinutils-redhat-9bbeae8fb85fc8e83c7684dcbc647faed08c3e27.tar.gz
* configure.ac (build_tools): Remove build-byacc.
(host_libs): Remove mmalloc. (host_tools): Remove byacc make patch prms send-pr ash bash bzip2 autoconf automake libtool diff rcs fileutils shellutils time textutils wdiff find uudecode hello tar gzip indent recode release sed perl gawk findutils gettext zip. (libgcj): Remove target-qthreads. (target_tools): Remove target-examples target-gperf. (YACC): Don't handle building byacc. * configure: Regenerate. * Makefile.def (ash, autoconf, automake, bash, byacc, bzip2, diff, dosutils, examples, fileutils, find, findutils, gawk, gettext, gnuserv, gperf, gzip, hello, indent, libtool, make, mmalloc, patch, perl, prms, qthreads, rcs, recode, release, sed, send-pr, shellutils, tar, textutils, time, uudecode, wdiff, zip): Don't handle building components. * Makefile.in: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index e6e91254c4..68208dcefb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,11 +128,11 @@ extra_host_args=
build_libs="build-libiberty"
# these tools are built for the build environment
-build_tools="build-texinfo build-byacc build-flex build-bison build-m4 build-fixincludes"
+build_tools="build-texinfo build-flex build-bison build-m4 build-fixincludes"
# these libraries are used by various programs built for the host environment
#
-host_libs="intl mmalloc libiberty opcodes bfd readline tcl tk itcl libgui zlib libcpp libdecnumber gmp mpfr mpc ppl cloog libelf libiconv"
+host_libs="intl libiberty opcodes bfd readline tcl tk itcl libgui zlib libcpp libdecnumber gmp mpfr mpc ppl cloog libelf libiconv"
# these tools are built for the host environment
# Note, the powerpc-eabi build depends on sim occurring before gdb in order to
@@ -140,12 +140,11 @@ host_libs="intl mmalloc libiberty opcodes bfd readline tcl tk itcl libgui zlib l
# binutils, gas and ld appear in that order because it makes sense to run
# "make check" in that particular order.
# If --enable-gold is used, "gold" may replace "ld".
-host_tools="texinfo byacc flex bison binutils gas ld fixincludes gcc cgen sid sim gdb make patch prms send-pr gprof etc expect dejagnu ash bash bzip2 m4 autoconf automake libtool diff rcs fileutils shellutils time textutils wdiff find uudecode hello tar gzip indent recode release sed utils guile perl gawk findutils gettext zip fastjar gnattools"
+host_tools="texinfo flex bison binutils gas ld fixincludes gcc cgen sid sim gdb gprof etc expect dejagnu m4 utils guile fastjar gnattools"
# libgcj represents the runtime libraries only used by gcj.
libgcj="target-libffi \
target-zlib \
- target-qthreads \
target-libjava"
# these libraries are built for the target environment, and are built after
@@ -173,7 +172,7 @@ target_libraries="target-libgcc \
# note: any program that *uses* libraries that are in the "target_libraries"
# list belongs in this list.
#
-target_tools="target-examples target-gperf target-rda"
+target_tools="target-rda"
################################################################################
@@ -2956,7 +2955,6 @@ MISSING=`cd $ac_aux_dir && ${PWDCMD-pwd}`/missing
AC_CHECK_PROGS([YACC], ['bison -y' byacc yacc], [$MISSING bison -y])
case " $build_configdirs " in
*" bison "*) YACC='$$r/$(BUILD_SUBDIR)/bison/tests/bison -y' ;;
- *" byacc "*) YACC='$$r/$(BUILD_SUBDIR)/byacc/byacc' ;;
esac
AC_CHECK_PROGS([BISON], [bison], [$MISSING bison])