summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Henderson <rth@redhat.com>2011-11-08 18:23:33 +0000
committerRichard Henderson <rth@redhat.com>2011-11-08 18:23:33 +0000
commitd06329a7ae430b780d56bbdf235da4fb3293fcca (patch)
treea27c82ffab130c97ba2d20bd5c19d7df7576bd4d /configure.ac
parentf9a3ddf690df9e555598241f1b8cd3d6f45ab505 (diff)
downloadbinutils-redhat-d06329a7ae430b780d56bbdf235da4fb3293fcca.tar.gz
Merge libitm changes to configure.ac from gcc master.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2745bd7d81..ea697d3932 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,6 +154,7 @@ target_libraries="target-libgcc \
target-libgloss \
target-newlib \
target-libgomp \
+ target-libitm \
target-libstdc++-v3 \
target-libmudflap \
target-libssp \
@@ -492,6 +493,22 @@ if test x$enable_libgomp = x ; then
esac
fi
+# Disable libitm on unsupported systems.
+if test -d ${srcdir}/libitm; then
+ if test x$enable_libitm = x; then
+ AC_MSG_CHECKING([for libitm support])
+ if (srcdir=${srcdir}/libitm; \
+ . ${srcdir}/configure.tgt; \
+ test -n "$UNSUPPORTED")
+ then
+ AC_MSG_RESULT([no])
+ noconfigdirs="$noconfigdirs target-libitm"
+ else
+ AC_MSG_RESULT([yes])
+ fi
+ fi
+fi
+
# Disable libssp for some systems.
case "${target}" in
avr-*-*)