summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2012-11-04 00:09:53 +0000
committerH.J. Lu <hjl.tools@gmail.com>2012-11-04 00:09:53 +0000
commitd91c19e1496411cc4976b62f182067fb1f2ced54 (patch)
tree7e7ec322daa47bb45348a2d21451710fffdb735f /configure.ac
parent590f7f6f276e70f222de51275207b2e26c215d2b (diff)
downloadbinutils-redhat-d91c19e1496411cc4976b62f182067fb1f2ced54.tar.gz
Add --disable-libstdcxx configure option
2012-11-03 H.J. Lu <hongjiu.lu@intel.com> * configure: Regenerated. 2012-11-03 Robert Mason <rbmj@verizon.net> * configure.ac: add --disable-libstdcxx configure option and handle defaulted state only for VxWorks, ARM-wince-pe and AVR.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 25 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 037f66a39b..c346c2cd53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -427,6 +427,15 @@ AC_ARG_ENABLE(libssp,
ENABLE_LIBSSP=$enableval,
ENABLE_LIBSSP=yes)
+AC_ARG_ENABLE(libstdcxx,
+AS_HELP_STRING([--disable-libstdcxx],
+ [do not build libstdc++-v3 directory]),
+ENABLE_LIBSTDCXX=$enableval,
+ENABLE_LIBSTDCXX=default)
+[if test "${ENABLE_LIBSTDCXX}" = "no" ; then
+ noconfigdirs="$noconfigdirs libstdc++-v3"
+fi]
+
# Save it here so that, even in case of --enable-libgcj, if the Java
# front-end isn't enabled, we still get libgcj disabled.
libgcj_saved=$libgcj
@@ -562,19 +571,22 @@ case "${target}" in
esac
# Disable libstdc++-v3 for some systems.
-case "${target}" in
- *-*-vxworks*)
- # VxWorks uses the Dinkumware C++ library.
- noconfigdirs="$noconfigdirs target-libstdc++-v3"
- ;;
- arm*-wince-pe*)
- # the C++ libraries don't build on top of CE's C libraries
- noconfigdirs="$noconfigdirs target-libstdc++-v3"
- ;;
- avr-*-*)
- noconfigdirs="$noconfigdirs target-libstdc++-v3"
- ;;
-esac
+# Allow user to override this if they pass --enable-libstdc++-v3
+if test "${ENABLE_LIBSTDCXX}" = "default" ; then
+ case "${target}" in
+ *-*-vxworks*)
+ # VxWorks uses the Dinkumware C++ library.
+ noconfigdirs="$noconfigdirs target-libstdc++-v3"
+ ;;
+ arm*-wince-pe*)
+ # the C++ libraries don't build on top of CE's C libraries
+ noconfigdirs="$noconfigdirs target-libstdc++-v3"
+ ;;
+ avr-*-*)
+ noconfigdirs="$noconfigdirs target-libstdc++-v3"
+ ;;
+ esac
+fi
# Disable Fortran for some systems.
case "${target}" in