summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2011-05-04 21:45:47 +0000
committerJoseph Myers <joseph@codesourcery.com>2011-05-04 21:45:47 +0000
commitf5a9f93ff1d5b816288d8314fcb2f87edc28cbe6 (patch)
treecea4ed52add8be7f458600f149bb7da640e47eb9 /configure.ac
parentdb03058379eceab949d197f794b96365507fd0de (diff)
downloadbinutils-redhat-f5a9f93ff1d5b816288d8314fcb2f87edc28cbe6.tar.gz
* configure.ac: Remove code setting special library locations for
hppa*64*-*-hpux11*. Remove code setting compiler for sparc-sun-solaris2*. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 0 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index c41abf3df6..bfbb80556d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2334,14 +2334,6 @@ if test x${with_stabs} = x ; then
esac
fi
-# hpux11 in 64bit mode has libraries in a weird place. Arrange to find
-# them automatically.
-case "${host}" in
- hppa*64*-*-hpux11*)
- extra_host_args="$extra_host_args -x-libraries=/usr/lib/pa20_64 -x-includes=/usr/X11R6/include"
- ;;
-esac
-
# Some systems (e.g., one of the i386-aix systems the gas testers are
# using) don't handle "\$" correctly, so don't use it here.
tooldir='${exec_prefix}'/${target_noncanonical}
@@ -2385,34 +2377,6 @@ case $we_are_ok in
esac
rm -f conftest*
-# The Solaris /usr/ucb/cc compiler does not appear to work.
-case "${host}" in
- sparc-sun-solaris2*)
- CCBASE="`echo ${CC-cc} | sed 's/ .*$//'`"
- if test "`type $CCBASE | sed 's/^[[^/]]*//'`" = "/usr/ucb/cc" ; then
- could_use=
- test -d /opt/SUNWspro/bin && could_use="/opt/SUNWspro/bin"
- if test -d /opt/cygnus/bin ; then
- if test "$could_use" = "" ; then
- could_use="/opt/cygnus/bin"
- else
- could_use="$could_use or /opt/cygnus/bin"
- fi
- fi
- if test "$could_use" = "" ; then
- echo "Warning: compilation may fail because you're using"
- echo "/usr/ucb/cc. You should change your PATH or CC "
- echo "variable and rerun configure."
- else
- echo "Warning: compilation may fail because you're using"
- echo "/usr/ucb/cc, when you should use the C compiler from"
- echo "$could_use. You should change your"
- echo "PATH or CC variable and rerun configure."
- fi
- fi
- ;;
-esac
-
# Decide which environment variable is used to find dynamic libraries.
case "${host}" in
*-*-hpux*) RPATH_ENVVAR=SHLIB_PATH ;;