summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDJ Delorie <dj@delorie.com>2002-06-19 23:39:41 +0000
committerDJ Delorie <dj@delorie.com>2002-06-19 23:39:41 +0000
commita5dc7af452acc0188edfd08bca34b6905c889242 (patch)
tree41a8d3cf9098bce297abdc6a25b64224e1b92e43 /configure.in
parentb72323eea17ade9b20b2d0df6b53191bc9ab5b7d (diff)
downloadbinutils-redhat-a5dc7af452acc0188edfd08bca34b6905c889242.tar.gz
* configure.in: Pull definition of is_cross_compiler earlier.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 12 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 33d1a9c894..e3974bd210 100644
--- a/configure.in
+++ b/configure.in
@@ -119,6 +119,14 @@ appdirs=""
# per-target:
+# Define is_cross_compiler to save on calls to 'test'.
+is_cross_compiler=
+if test x"${host}" = x"${target}" ; then
+ is_cross_compiler=no
+else
+ is_cross_compiler=yes
+fi
+
# Don't use libstdc++-v3's flags to configure/build itself.
libstdcxx_flags='`case $$dir in libstdc++-v3 | libjava) ;; *) test ! -f $$r/$(TARGET_SUBDIR)/libstdc++-v3/testsuite_flags || $(SHELL) $$r/$(TARGET_SUBDIR)/libstdc++-v3/testsuite_flags --build-includes;; esac` -L$$r/$(TARGET_SUBDIR)/libstdc++-v3/src -L$$r/$(TARGET_SUBDIR)/libstdc++-v3/src/.libs'
@@ -426,19 +434,10 @@ esac
# toolchains, we add some directories that should only be useful in a
# cross-compiler.
-is_cross_compiler=
-
-if test x"${host}" = x"${target}" ; then
- # when doing a native toolchain, don't build the targets
- # that are in the 'cross only' list
- skipdirs="${skipdirs} ${cross_only}"
- is_cross_compiler=no
-else
- # similarly, don't build the targets in the 'native only'
- # list when building a cross compiler
- skipdirs="${skipdirs} ${native_only}"
- is_cross_compiler=yes
-fi
+case $is_cross_compiler in
+ no) skipdirs="${skipdirs} ${cross_only}" ;;
+ yes) skipdirs="${skipdirs} ${native_only}" ;;
+esac
# We always want to use the same name for this directory, so that dejagnu
# can reliably find it.