summaryrefslogtreecommitdiff
path: root/gas/Makefile.am
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-09-03 22:11:21 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-09-03 22:11:21 +0000
commit0fd2feb82d9f412e6b5b28272da08ad6491c43eb (patch)
tree3128f4d9d5c720dab2696b2d2c2be5b27afb53eb /gas/Makefile.am
parent7ed3a81f791120eb36a69f37d9faa6b5e286929c (diff)
downloadbinutils-redhat-0fd2feb82d9f412e6b5b28272da08ad6491c43eb.tar.gz
Fix itbl-parse.h dependencies in gas.
gas/: * Makefile.am (itbl-lex.o): Depend on itbl-parse.h. (itbl-ops.o, itbl-tops.o): Likewise. (itbl-parse.h): Use separate rule. * Makefile.in: Regenerate.
Diffstat (limited to 'gas/Makefile.am')
-rw-r--r--gas/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/gas/Makefile.am b/gas/Makefile.am
index a76860f934..1f78c71061 100644
--- a/gas/Makefile.am
+++ b/gas/Makefile.am
@@ -627,7 +627,7 @@ endif
# Disable -Werror, if it has been enabled, since old versions of bison/
# yacc will produce working code which contain compile time warnings.
-itbl-lex.o: itbl-lex.c
+itbl-lex.o: itbl-lex.c itbl-parse.h
if am__fastdepCC
$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `test -f itbl-lex.c || echo $(srcdir)/`itbl-lex.c $(NO_WERROR)
mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@@ -653,16 +653,20 @@ endif
$(COMPILE) -c `test -f itbl-parse.c || echo $(srcdir)/`itbl-parse.c $(NO_WERROR)
endif
-itbl-parse.c itbl-parse.h: $(srcdir)/itbl-parse.y
+itbl-parse.c: $(srcdir)/itbl-parse.y
$(SHELL) $(YLWRAP) $(srcdir)/itbl-parse.y y.tab.c itbl-parse.c y.tab.h itbl-parse.h -- $(YACCCOMPILE) -d
+itbl-parse.h: itbl-parse.c ; @true
+
+itbl-ops.o: itbl-parse.h
+
# stand-alone itbl assembler & disassembler
EXTRA_PROGRAMS = itbl-test
itbl_test_SOURCES = itbl-parse.y itbl-lex.l
itbl_test_LDADD = itbl-tops.o itbl-test.o $(GASLIBS) @LEXLIB@
-itbl-tops.o: itbl-ops.c
+itbl-tops.o: itbl-ops.c itbl-parse.h
if am__fastdepCC
$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -o $@ -c -DSTAND_ALONE $(srcdir)/itbl-ops.c
mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po