summaryrefslogtreecommitdiff
path: root/gas/Makefile.am
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-09-01 20:56:51 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-09-01 20:56:51 +0000
commit86d801ff877e906d84495b387398b3f7afd5a71f (patch)
treeba258e9cf5d2168d0ea4701754c5ce4422dc8c61 /gas/Makefile.am
parentc61de5b18f2e201785764f49c7fd4f01e367c492 (diff)
downloadbinutils-redhat-86d801ff877e906d84495b387398b3f7afd5a71f.tar.gz
Fix VPATH search for generated sources in binutils, gas, ld.
binutils/: * Makefile.am (arparse.o, arlex.o, sysroff.o, defparse.o) (deflex.o, nlmheaders.o, rcparse.o, mcparse.o): Supply correct source file name for generated files which may be in $(srcdir). * Makefile.in: Regenerate. gas/: * Makefile.am (m68k-parse.o, bfin-lex.o, itbl-lex.o, itbl-parse.o): Supply correct source file name for generated files which may be in $(srcdir). * Makefile.in: Regenerate. ld/: * Makefile.am (ldgram.o, ldlex.o, deffilep.o): Supply correct source file name for generated files which may be in $(srcdir). * Makefile.in: Regenerate.
Diffstat (limited to 'gas/Makefile.am')
-rw-r--r--gas/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/gas/Makefile.am b/gas/Makefile.am
index b8e86b14ba..a76860f934 100644
--- a/gas/Makefile.am
+++ b/gas/Makefile.am
@@ -586,14 +586,14 @@ m68k-parse.c: $(srcdir)/config/m68k-parse.y
# yacc will produce working code which contain compile time warnings.
m68k-parse.o: m68k-parse.c
if am__fastdepCC
- $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ m68k-parse.c $(NO_WERROR)
+ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `test -f m68k-parse.c || echo $(srcdir)/`m68k-parse.c $(NO_WERROR)
mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
else
if AMDEP
source='m68k-parse.c' object='$@' libtool=no @AMDEPBACKSLASH@
DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
endif
- $(COMPILE) -c m68k-parse.c $(NO_WERROR)
+ $(COMPILE) -c `test -f m68k-parse.c || echo $(srcdir)/`m68k-parse.c $(NO_WERROR)
endif
# Don't let the .y.h rule clobber m68k-parse.h.
@@ -613,14 +613,14 @@ bfin-lex.c: $(srcdir)/config/bfin-lex.l
$(SHELL) $(YLWRAP) $(srcdir)/config/bfin-lex.l lex.yy.c bfin-lex.c -- $(LEXCOMPILE)
bfin-lex.o: bfin-lex.c
if am__fastdepCC
- $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ bfin-lex.c $(NO_WERROR)
+ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `test -f bfin-lex.c || echo $(srcdir)/`bfin-lex.c $(NO_WERROR)
mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
else
if AMDEP
source='bfin-lex.c' object='$@' libtool=no @AMDEPBACKSLASH@
DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
endif
- $(COMPILE) -c bfin-lex.c $(NO_WERROR)
+ $(COMPILE) -c `test -f bfin-lex.c || echo $(srcdir)/`bfin-lex.c $(NO_WERROR)
endif
# The instruction table specification lexical analyzer and parser.
@@ -629,28 +629,28 @@ endif
# yacc will produce working code which contain compile time warnings.
itbl-lex.o: itbl-lex.c
if am__fastdepCC
- $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ itbl-lex.c $(NO_WERROR)
+ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `test -f itbl-lex.c || echo $(srcdir)/`itbl-lex.c $(NO_WERROR)
mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
else
if AMDEP
source='itbl-lex.c' object='$@' libtool=no @AMDEPBACKSLASH@
DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
endif
- $(COMPILE) -c itbl-lex.c $(NO_WERROR)
+ $(COMPILE) -c `test -f itbl-lex.c || echo $(srcdir)/`itbl-lex.c $(NO_WERROR)
endif
# Disable -Werror, if it has been enabled, since old versions of bison/
# yacc will produce working code which contain compile time warnings.
itbl-parse.o: itbl-parse.c
if am__fastdepCC
- $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ itbl-parse.c $(NO_WERROR)
+ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `test -f itbl-parse.c || echo $(srcdir)/`itbl-parse.c $(NO_WERROR)
mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
else
if AMDEP
source='itbl-parse.c' object='$@' libtool=no @AMDEPBACKSLASH@
DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
endif
- $(COMPILE) -c itbl-parse.c $(NO_WERROR)
+ $(COMPILE) -c `test -f itbl-parse.c || echo $(srcdir)/`itbl-parse.c $(NO_WERROR)
endif
itbl-parse.c itbl-parse.h: $(srcdir)/itbl-parse.y