summaryrefslogtreecommitdiff
path: root/gas/Makefile.am
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2009-08-06 17:38:04 +0000
committerNick Clifton <nickc@redhat.com>2009-08-06 17:38:04 +0000
commitad627b386b6942f5ca67d6374afaa9853f74cdbf (patch)
treedc720185e27e125c1198439422ae8c2569c8cf63 /gas/Makefile.am
parent560c595224d5a41856e15532ebcc2e09682bb5fd (diff)
downloadbinutils-redhat-ad627b386b6942f5ca67d6374afaa9853f74cdbf.tar.gz
Add support for Xilinx MicroBlaze processor.
* bfd/Makefile.am: Add cpu-microblaze.{lo,c}, elf32-microblaze.{lo,c}. * bfd/Makefile.in: Same. * bfd/archures.c: Add bfd_arch_microblaze. * bfd/bfd-in2.h: Regenerate. * bfd/config.bfd: Add microblaze target. * bfd/configure: Add bfd_elf32_microblaze_vec target. * bfd/configure.in: Same. * bfd/cpu-microblaze.c: New. * bfd/elf32-microblaze.c: New. * bfd/libbfd-in.h: Add prototype _bfd_dwarf2_fixup_section_debug_loc(). * bfd/libbfd.h: Regenerate. * bfd/reloc.c: Add MICROBLAZE relocations. * bfd/section.c: Add struct relax_table and relax_count to section. * bfd/targets.c: Add bfd_elf32_microblaze_vec. * binutils/MAINTAINERS: Add self as maintainer. * binutils/readelf.c: Include elf/microblaze.h, add EM_MICROBLAZE & EM_MICROBLAZE_OLD to guess_is_rela(), dump_relocations(), get_machine_name(). * config.sub: Add microblaze target. * configure: Same. * configure.ac: Same. * gas/Makefile.am: add microblaze to CPU_TYPES, config/tc-microblaze.c to TARGET_CPU_CFILES, config/tc-microblaze.h to TARGET_CPU_HFILES, add DEP_microblaze_elf target. * gas/Makefile.in: Same. * gas/config/tc-microblaze.c: Add MicroBlaze assembler. * gas/config/tc-microblaze.h: Add header for tc-microblaze.c. * gas/configure: Add microblaze target. * gas/configure.in: Same. * gas/configure.tgt: Same. * gas/doc/Makefile.am: Add c-microblaze.texi to CPU_DOCS. * gas/doc/Makefile.in: Same. * gas/doc/all.texi: Set MICROBLAZE. * gas/doc/as.texinfo: Add MicroBlaze doc links. * gas/doc/c-microblaze.texi: New MicroBlaze docs. * include/dis-asm.h: Decl print_insn_microblaze(). * include/elf/common.h: Define EM_MICROBLAZE & EM_MICROBLAZE_OLD. * include/elf/microblaze.h: New reloc definitions. * ld/Makefile.am: Add eelf32mb_linux.o, eelf32microblaze.o to ALL_EMULATIONS, targets. * ld/Makefile.in: Same. * ld/configure.tgt: Add microblaze*-linux*, microblaze* targets. * ld/emulparams/elf32mb_linux.sh: New. * ld/emulparams/elf32microblaze.sh. New. * ld/scripttempl/elfmicroblaze.sc: New. * opcodes/Makefile.am: Add microblaze-opc.h to HFILES, microblaze-dis.c to CFILES, microblaze-dis.lo to ALL_MACHINES, targets. * opcodes/Makefile.in: Same. * opcodes/configure: Add bfd_microblaze_arch target. * opcodes/configure.in: Same. * opcodes/disassemble.c: Define ARCH_microblaze, return print_insn_microblaze(). * opcodes/microblaze-dis.c: New MicroBlaze disassembler. * opcodes/microblaze-opc.h: New MicroBlaze opcode definitions. * opcodes/microblaze-opcm.h: New MicroBlaze opcode types.
Diffstat (limited to 'gas/Makefile.am')
-rw-r--r--gas/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/gas/Makefile.am b/gas/Makefile.am
index 550132570f..0ceb546d16 100644
--- a/gas/Makefile.am
+++ b/gas/Makefile.am
@@ -72,6 +72,7 @@ CPU_TYPES = \
maxq \
mcore \
mep \
+ microblaze \
mips \
mmix \
mn10200 \
@@ -273,6 +274,7 @@ TARGET_CPU_CFILES = \
config/tc-maxq.c \
config/tc-mcore.c \
config/tc-mep.c \
+ config/tc-microblaze.c \
config/tc-mips.c \
config/tc-mmix.c \
config/tc-mn10200.c \
@@ -334,6 +336,7 @@ TARGET_CPU_HFILES = \
config/tc-maxq.h \
config/tc-mcore.h \
config/tc-mep.h \
+ config/tc-microblaze.h \
config/tc-mips.h \
config/tc-mmix.h \
config/tc-mn10200.h \
@@ -1788,6 +1791,19 @@ DEPTC_mep_elf = \
cgen.h \
dwarf2dbg.h \
subsegs.h
+DEPTC_microblaze_elf = \
+ $(srcdir)/config/obj-elf.h \
+ $(BFDDIR)/elf-bfd.h \
+ $(INCDIR)/elf/common.h \
+ $(INCDIR)/elf/internal.h \
+ $(INCDIR)/elf/external.h \
+ $(INCDIR)/bfdlink.h \
+ $(srcdir)/config/tc-microblaze.h \
+ $(INCDIR)/obstack.h \
+ $(srcdir)/../opcodes/microblaze-opc.h \
+ $(INCDIR)/elf/reloc-macros.h \
+ emul.h \
+ subsegs.h
DEPTC_mips_coff = \
$(BFDDIR)/elf-bfd.h \
$(BFDDIR)/libcoff.h \
@@ -3921,6 +3937,14 @@ DEP_mep_elf = \
$(srcdir)/config/obj-elf.h \
$(srcdir)/config/tc-mep.h \
dwarf2dbg.h
+DEP_microblaze_elf = \
+ $(srcdir)/config/obj-elf.h \
+ $(BFDDIR)/elf-bfd.h \
+ $(INCDIR)/elf/common.h \
+ $(INCDIR)/elf/internal.h \
+ $(INCDIR)/elf/external.h \
+ $(INCDIR)/bfdlink.h \
+ $(srcdir)/config/tc-microblaze.h
DEP_mips_coff = \
$(BFDDIR)/libcoff.h \
$(INCDIR)/bfdlink.h \