summaryrefslogtreecommitdiff
path: root/gas/Makefile.am
diff options
context:
space:
mode:
authorCary Coutant <ccoutant@google.com>2010-07-03 20:52:22 +0000
committerCary Coutant <ccoutant@google.com>2010-07-03 20:52:22 +0000
commitb0b499c4d40a6329b30f41cc40ac9c7880f74a62 (patch)
tree1f51b5c301bc54d17329b9bd1d5c926e3c7aaee6 /gas/Makefile.am
parent868599c9ad52c88d280699558f6aaf1316f815e9 (diff)
downloadbinutils-redhat-b0b499c4d40a6329b30f41cc40ac9c7880f74a62.tar.gz
bfd/ChangeLog:
* compress.c (bfd_uncompress_section_contents): Add ATTRIBUTE_UNUSED. * dwarf2.c (read_and_uncompress_section): New function. (read_section): Call it. (find_line): Likewise. binutils/ChangeLog: * objdump.c (load_specific_debug_section): Decompress section contents before applying relocations. * readelf.c (load_specific_debug_section): Update section size after decompression. gas/ChangeLog: * Makefile.am: Add compress-debug.c and compress-debug.h. * Makefile.in: Regenerate. * config.in: Add HAVE_ZLIB_H. * configure.in: Check for zlib.h. * configure: Regenerate. * as.c (parse_args): Add --compress-debug-sections and --nocompress-debug-sections. * as.h (flag_compress_debug): New variable. * compress-debug.c: New file. * compress-debug.h: New file. * write.c: Include compress-debug.h. (compress_frag): New function. (compress_debug): New function. (write_object_file): Compress debug sections if requested.
Diffstat (limited to 'gas/Makefile.am')
-rw-r--r--gas/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gas/Makefile.am b/gas/Makefile.am
index d23b472d7c..6971f73c73 100644
--- a/gas/Makefile.am
+++ b/gas/Makefile.am
@@ -43,6 +43,7 @@ GAS_CFILES = \
app.c \
as.c \
atof-generic.c \
+ compress-debug.c \
cond.c \
depend.c \
dwarf2dbg.c \
@@ -78,6 +79,7 @@ HFILES = \
bignum.h \
bit_fix.h \
cgen.h \
+ compress-debug.h \
dwarf2dbg.h \
dw2gencfi.h \
ecoff.h \