summaryrefslogtreecommitdiff
path: root/gas/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2005-04-14 05:26:44 +0000
committerAlan Modra <amodra@bigpond.net.au>2005-04-14 05:26:44 +0000
commitd8e6c8fbe4d7492874b642e1576ef11897a1852e (patch)
treee125628ccea2a248701e6565f68dba18b58701e4 /gas/Makefile.am
parentfc491c7433f60e1bc22465b881cbc958a4b213db (diff)
downloadbinutils-redhat-d8e6c8fbe4d7492874b642e1576ef11897a1852e.tar.gz
bfd/
* Makefile.am (NO_WERROR): Define. * warning.m4: New file * acinclude.m4: Include warning.m4. * configure.in: Invoke AM_BINUTILS_WARNINGS. * Makefile.in: Regenerate. * configure: Regenerate. bfd/doc/ * Makefile.in: Regenerate. binutils/ * Makefile.am (NO_WERROR): Define. Use instead of -Wno-error. * configure.in: Include ../bfd/warning.m4 contents. * Makefile.in: Regenerate. * configure: Regenerate. * doc/Makefile.in: Regenerate. gas/ * Makefile.am (NO_WERROR): Define. Use instead of -Wno-error. * acinclude.m4: Include ../bfd/warning.m4. * configure.in: Invoke AM_BINUTILS_WARNINGS. * Makefile.in: Regenerate. * configure: Regenerate. * doc/Makefile.in: Regenerate. gprof/ * Makefile.am (NO_WERROR): Define. * acinclude.m4: Include ../bfd/warning.m4. * configure.in: Invoke AM_BINUTILS_WARNINGS. * Makefile.in: Regenerate. * aclocal.m4: Regenerate. * configure: Regenerate. ld/ * Makefile.am (NO_WERROR): Define. Use instead of -Wno-error. * configure.in: Include ../bfd/warning.m4 contents. * Makefile.in: Regenerate. * configure: Regenerate. opcodes/ * Makefile.am (NO_WERROR): Define. * configure.in: Invoke AM_BINUTILS_WARNINGS. * Makefile.in: Regenerate. * aclocal.m4: Regenerate. * configure: Regenerate.
Diffstat (limited to 'gas/Makefile.am')
-rw-r--r--gas/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gas/Makefile.am b/gas/Makefile.am
index c03e580595..11fc5f7a14 100644
--- a/gas/Makefile.am
+++ b/gas/Makefile.am
@@ -16,6 +16,7 @@ YACC = `if [ -f ../bison/bison ] ; then echo ../bison/bison -y -L../bison/bison
LEX = `if [ -f ../flex/flex ] ; then echo ../flex/flex ; else echo @LEX@ ; fi`
WARN_CFLAGS = @WARN_CFLAGS@
+NO_WERROR = @NO_WERROR@
AM_CFLAGS = $(WARN_CFLAGS)
MKDEP = gcc -MM
@@ -644,7 +645,7 @@ m68k-parse.c: $(srcdir)/config/m68k-parse.y
# Disable -Werror, if it has been enabled, since old versions of bison/
# yacc will produce working code which contain compile time warnings.
m68k-parse.o: m68k-parse.c $(srcdir)/config/m68k-parse.h
- $(COMPILE) -c $< -Wno-error
+ $(COMPILE) -c $< $(NO_WERROR)
# Don't let the .y.h rule clobber m68k-parse.h.
m68k-parse.h: ; @true
@@ -658,7 +659,7 @@ itbl-lex.o: itbl-lex.c itbl-parse.h $(srcdir)/itbl-lex.h
# Disable -Werror, if it has been enabled, since old versions of bison/
# yacc will produce working code which contain compile time warnings.
itbl-parse.o: itbl-parse.c itbl-parse.h $(srcdir)/itbl-ops.h $(srcdir)/itbl-lex.h
- $(COMPILE) -c $< -Wno-error
+ $(COMPILE) -c $< $(NO_WERROR)
itbl-ops.o: $(srcdir)/itbl-ops.c $(srcdir)/itbl-ops.h itbl-parse.h